Web disconnections with 2021r3

I think this thread should not have been archived, the problem persists.
After dozens of tests, I think I have found a certain clue to follow:
CASE OF DISCONNECTED (the session is disconnected at intervals of 5-7-10 seconds depending on its use on a Linux server and never on Windows 10)

  • WebPage type HomePage calls another WebPage containing 2 ContainerControl:
    • 1 ContainerControl visible with a WebListbox, a SearchField and a Button that loads the WebListbox with a BD MySql table.
    • If you choose a row it shows you 2 ContainerControl with different TextFields, Tab with several tabs and Buttons.
      You can search again, it hides Container2 and shows Container1 again to choose again in WebListBox or new search.

CASE WITHOUT DISCONNECTED (session never disconnects on Windows or Linux server)

  • WebPage type HomePage calls another WebPage that does NOT contain any ContainerControl:
    There is a WebListBox, SearchField and Button that appear visible and an invisible Tab with several tabs that contain Textfields, buttons and WeblistBox.
    A row is chosen, hides the first search fields and WebListbox and shows the Tab with the various tabs, Textfields, etc.
    You can search again by hiding and showing fields without problem, any interaction you make never causes disconnection.

My summary for now: ContainerControl is the main suspect for causing disconnections, perhaps by containing WebListbox, showing and hiding …
But here there is a way to continue testing.

1 Like

Since 2021r3 has been released, you may get better feedback putting this in the public Web channel?

Also, when you see the disconnect, what does the Javascript console say? What about the Xojo web app logs?

2 Likes

In the same test environment as in production I get:

Failed to load resource: net::ERR_INCOMPLETE_CHUNKED_ENCODING

Only however on a linux server with web app behind apache. If I access the webapp via its port (e.g. 8080) no disconnection is generated.

2 Likes

Having the same problems. Web App behind Nginx (Lifeboat) or behind any other reverse proxy gets disconnected. (Unbuntu 20.04/ Centos 7).

Also happens when nothing is done. Only staying at a Webpage. Nothing running, no database.

Same app direct access Port 8080 works.

Same app with 2021R2.1 works with reverse proxy.

@Greg_O_Lone … Any Ideas ? Its not the app itself, it seems something has changed with 2021R3 monitoring an active connection … not working reliable with a reverse proxy.

I’m continuing to test, but I’m not coming out of it anymore. I tried apache, nginx (always on centos7) changing all possible parameters but it’s not a server side problem(see here). So I started taking out various sections of my app to no avail. For now the only thing that could give problems are the connections with the MariaDB(mysql) database. There is like a timeout somewhere in 2021r3 that causes these disconnections.

Httpd log:

[proxy_http:error] [pid 1051:tid 140063488853760] (70007)The specified timeout has expired: [client x.x.x.x:59595] AH01110: error reading response, referer:

Nginx log:

[error] 6266#6266: *68 upstream timed out (110: Connection timed out) while reading upstream, client: x.x.x.x, server: , request:
“GET /5882726F4F16DE94AD11E183F7D5E410DE6681C0838CBB3120779E63A6DCEBA4/comm/serverevent HTTP/1.1”, upstream:
http://127.0.0.1:8080/5882726F4F16DE94AD11E183F7D5E410DE6681C0838CBB3120779E63A6DCEBA4/comm/serverevent”, host: “x.x.x.x”, referrer: “http://x.x.x.x/

1 Like

Same here

Javascript Console (when disconnecting)

GET https://xxxx/CA16F18E666C9EF15925108CCBF4DA22CD225DB186E4874021AC7E58BBEEA310/comm/serverevent net::ERR_INCOMPLETE_CHUNKED_ENCODING 200 (OK)

1 Like

feedback://showreport?report_id=66779

You did well to create the feedback, unfortunately without a test project I don’t know if it will ever be considered. I will add points to this.

It is reproducable with Eddie’s Electronics Xojo Web demo. Uploaded with Lifeboat on an Ubuntu 20.04 Server.

Edit: added Picture

5 Likes

Great idea, I hadn’t thought of that. I threw away days of testing for nothing. Thanks

1 Like

Did the same right now and yep it doesn’t take to much time to get the “white window of disconnection” :slight_smile:
Steps to reproduce: just upload the webapp, open it in any browser and do nothing or do something, it doesn’t matter.

Just booked a xojo cloud Server.

Same error

https://66679.xojocloud.net/ (Build with 2021R3)

(Build with 2021R2.1 works)

Edit: added Build Infos

Now xojo Team its your turn ;-). (after thanksgiving weekend)

5 Likes

I can definatly confirm this is happening on MacOS safari too… thanks for making it clear.
Not sure why it gives the erro but we’re a step forward.

If you had listened to me in the pre-release phase :roll_eyes:… Hopefully it will be fixed soon, I’ve been going crazy looking for any issues in my code/server configuration. At this point I wonder how many are using the r3 version in proxy :flushed: … crazy that no one noticed this before.

Edit: Sorry I thought you meant debug mode.

This interesting bit of information means that it’s not the reverse proxy configuration and is actually a problem with the app itself :grimacing:

1 Like

It means it’s most likely xojo itself but again my server (2021R3, lifeboart debian) has not had such effects…Thus it may be coming from a certain control or something else.

So is everyone experiencing this issue using a reverse proxy of some kind? Xojo Cloud, Lifeboat, or manually? Does this occur in debug mode?

As i can see only with any kind of reverse proxy. AND only in 2021R3. Now with Xojo Demo App and Xojo Cloud … they should be able to fix it.

I have this issue with lifeboat installing app on ubuntu.

Can anyone reproduce this when deploying to Xojo Cloud with r3 though? We too have Apache set up as a load balancer and reverse proxy and I’m not aware of any issues with that combination yet.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.