Waiting for debugger Android Xojo2023r2 on Linux

Screenshot from 2023-08-09 22-15-11

Running an android app in the new r2 on Linux seems to wait forever for the debugger on a virtual device. However when force quitting the process on the virtual device you can see it did successfully install the app. I’m not sure if I did something wrong or if it is a bug but happy to see the Android platform and r2… All on my birthday :slight_smile:

Operating System: Kubuntu 23.04 (Ubuntu)
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.2.0-26-generic (64-bit)
Graphics Platform: X11

You might want to try an actual device connected via USB to see if that helps.

Does it connect if you stop the app and try to run it again?

Does the Android Debug Bridge start?

Is there anything in the IDE Messages area?

Try starting Xojo from the command line and see if any extra information about this gets written to the terminal.

Here is my terminal messages:

~$ /opt/xojo/xojo2023r2/Xojo
Xojo: /home/[USER]/Android/Sdk/platform-tools//adb -s List of shell getprop ro.product.manufacturer
adb: unknown command of
AndroidInstallShellResult: Performing Streamed Install

AndroidLaunchCommand: /home/[USER]/Android/Sdk/platform-tools//adb -s emulator-5554 shell am start -a android.intent.action.MAIN -D -n com.alwaysofflinesoftware.test/.screen1
AndroidLaunchShellResult: Starting: Intent { act=android.intent.action.MAIN cmp=com.alwaysofflinesoftware.test/.screen1 }

kf.service.services: KApplicationTrader: mimeType "x-scheme-handler/file" not found

When I hit stop in the IDE I get this message:

However I am not running Android studio, it is not open in my background processes besides the emulator device of course. I have not tried a physical device but I can later.

Ok so I found out how to work-around this, first seems to be a bug in KDE:

a workaround has been found - you need to:
enable hidden files in dolphin then go to your home dir (/home/username) then go to hidden .config dir in there you need to find file named mimeapps.list edit it, add this string (x-scheme-handler/file=org.kde.dolphin.desktop;) to all sub strings for example:

[Added Associations]

[Default Applications]


but NOT in [Removed Associations]

then execute this command in the terminal: update-mime-database ~/.local/share/mime
it’s worked for me, after that system links has became open in dolphin


Then you need to go to
“/opt/xojo/xojo2023r2/Xojo Resources/Frameworks/Android/xadbGUI/”

and change the owner of “xadbGUI” from root to your user and group:
sudo chown [user]:[user] xadbGUI

After following these steps the debugger connects and it seems to work as intended.


This work around worked for me also. I am running the latest xojo 2024r1.1 and Mint Linux 21.3 Virginia. I was getting the same error with the debugger. I haven’t learned the technique yet to connect directly to a device yet…brand noob’y to Xojo, but excited to begin playing with Android.

Thanks for the work around,

1 Like

I just make APK file and then use an application called localsend to put it on my testing phone.
It might not be streamlined but it’s as real of a scenario as possible so not all bad.
The emulator works good enough for 75% of my testing if I had to put a number on it.