Wacom tablet stuff not working

I have a Wacom tablet and I was trying to read the pen input but nothing seems to work.
The System.PenType() always returns that I’m using a mouse (when I do use a mouse) and doesn’t detect when I’m using the pen to “click”.
And the System.Pressure() always returns 0.
Is there anything else that must be done to correctly read the pen state?
Oh, I’m on a iMac, running Catalina.

Do you have the Wacom drivers installed?

Yes, I do.
I use my Wacom with other softwares that does recognise the pressure, as it is expected.

Tested 2020r2.1 on High Sierra with Wacom tablet and PenType is 0.

Thank you, Beatrix.
And the System.PenPressure() always returns 0, right?
I don’t know if you tested that.

Anyone else with the same problem?
Or, better yet, with a solution? :slightly_smiling_face:

Could it be that Xojo is not working with the latest Wacom drivers anymore?

Has anyone else tested this, and managed to read the pressure?

Tried all Pen functions.
The PenButtonPushed returns nothing, no matter what button I press and whatever index I provide.
The PenType always returns 0.
The PenPressure always returns 0.0

And I tested the pen in many applications that read the pen pressure. And it all worked fine. I have the latest Wacom driver installed.
My pen is an Intuos and it works wired and wirelessly. I tried both ways and nothing seems to work.
Anyone could help out?
Thank you.

Just adding a little more information.
My Wacom tablet is an Intuos S tablet. It is wireless but can also work with the USB cable attached. I tried it both way and none worked.
Well, it just doesn’t work with the Xojo commands to read the pressure or the click, using the pen, because the pen is working fine with applications that do read the pressure, like Affinity Designer or Affinity Photo.
Does anyone has a simple project file that is working in reading the pen pressure, so that I can rule out any problems with my own system (MacOS Catalina 10.15.7)?

Probably not the answer you are looking for, but, Are you sure Xojo is the right tool for what you need? There is almost no one using if for graphics so it is totally posible to be a Xojo bug that no one have reportet because there a re no others using this. So, low level priority if its a bug, could be months if you are lucky and is in the next release, could be years if not.

1 Like

You are right in both aspects.
It is not the answer I’m looking for :wink:
And there will probably not get a fix in a short time.
Maybe I just wanted to make sure it is a bug and no one could really make it work.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.