VBRUN Error When adding an ActiveX object

When I add an ActiveX object to the project (it creates some code by itself) and try to run it, it gives an error “This item does not exist” pointing to VBRUN. I tried to install VB 6.0 runtime environment, but still the error is there. Could anybody point me the right direction. I am on windows 8

It might be a VB5 DLL.
Where did it come from?

I just added an activex control into the xojo project and tried to run it. while adding the activex control xojo automatically generates some code for the control. It gives the error from this source. VBRUN.Dataobject does not exist. Do I need to install any Visual Basic runtimes?

Well it will depend on the activex control.
Some are written in VB itself and do require the runtimes.
Some are written in C and don’t.
Sounds like yours does.

You installed VBrun600… go install VBrun5 runtimes and see what happens.
Which actives is it?

To prevent such an error from happening to your customers, you can drop the vbrun dll directly into your project explorer and write the file to harddrive and register it during the App.Open Event.

Register the DLL from your source code using the Shell Class and calling:

Shell.Execute "regsvr32 /s vbrun_.dl"

using the name of your dll to register with the system. I have seen this error primarily if Comdlg32 is not installed…