Using the remote debugger with VirtualBox

I’ve been trying to get remote debugging to work with VirtualBox. The host machine is running Windows 7 and the guest OS might be any supported version of Windows (XP-8). It never connects, however, and I’m wondering if anyone has used VirtualBox for remote debugging. Any help would be appreciated.

I am able to do this. Make sure your VM has a bridged network adaptor & either turn off the Windows firewall or make an exception.

OK, I changed the adapter to to bridged mode, disabled the firewall on both the guest and host OSes, but I still get the “malicious termination” message when trying to connect. Any thoughts?

Can you ping in both directions?

I can ping from the host to the VM, but not from the VM to the host. However, I installed Xojo in the VM and I was was able to connect to the remote debugger running on the host (the reverse of what I want).

I installed Linux Mint in another VM and once the adapter was set to bridged mode the remote debugger worked. The one difference I noticed was that once the Mint VM was set to bridged, the VM’s IP changed to a 192.168.1.* address where previously it had been 10.0.2.* XP, however, kept the 10.0.2.* IP and I’m pretty sure the problem is somewhere in that general direction. Networking isn’t exactly one of my strengths. Xojo also autodetected the Mint VM whereas it doesn’t do so with the XP VM.

I’d delete the network interface in the VM & reinstall it. Go to the device manager, delete the network card then scan for changes. PM me if you want me to help with teamviewer.



If i remember (off the top of my head) when you install Virtualbox it creates a virtual network adapter with a default IP address of known as a host only adapter which also acts as a virtual dhcp server. If you set your VM’s to use ‘host only adapter’ rather than bridge/Nat you should be able to communicate both ways.

Also try disabling windows firewall and IP tables in your VM’s temporarily “sudo service stop iptables” just to rule out any TCP/UDP issues.

That did it! I went further and changed the virtual adapter type in the VM settings to one of the alternate models (in bridged mode), disabled every firewall within a 20 meter radius, and everything’s working now.


i set the VM to used Bridged Adapter and it still does not connect. i already turn off the firewall.

i got it to work… all i need to do is shutdown the VM and start again.

i think the latest maintenance version of VirtualBox kill off my remote debug.

Great tip!

remember to put the remote debug folder in drive c and not the virtual shared drive. and create a ‘remote debug area’ on drive c too… and set the location on remote debug program to the ‘remote debug area’