Updated my web app and now I'm buggered

I’m in a pickle, just broken my serial/activation system by upgrading it.

I keep getting these message in the server log, I’ve renamed the application name for security.

[quote][Sat Feb 25 07:05:56 2017] [error] [client] Script timed out before returning headers: xxxxx.cgi
[Sat Feb 25 07:06:56 2017] [warn] [client] Timeout waiting for output from CGI script /home/ow1537a/cgi-bin/xxxxx/xxxxx.cgi[/quote]

I’ve even reverted the code back to what it was, gone back to the previous Xojo version and re-built (so it will be the same as before).
I’ve removed the cgi file and then SSH in and killed the processes, then replaced them and ensured that all files have the ‘executable’ bit set.

If I do a ps -ef -f on the server, I can see multiple copies of the cgi running and one copy of the application running.
On launch the app connects to it’s database an writes a log entry indicating that the application is up and running. If I remove the cgi file and wait for a minute or so, it writes another entry indicating that it’s noticed the file is missing and shuts down. So IMHO the application is running.

Suggestions, please? I’m a bit desperate.

Tried it with both Xojo 2016r1.1 and 2016r4.1.

Used Time Machine to restore original source code and I’m still getting the same issue.

Stop the web app process then re-upload.
Upload the app executable again using binary mode.

Re-try the above mostly works

[quote=317813:@Derk Jochems]Stop the web app process then re-upload.
Upload the app executable again using binary mode.

Re-try the above mostly works[/quote]
Thanks Derk, tried that already. In total I’ve re-uploaded 5 times already in the past hour or so.

Can anyone confirm if the .htmaccess is correct or not?

[quote]Options +ExecCGI
order allow,deny
deny from all
<Files *.cgi>
allow from all


rebooted the server?

Sadly no difference.

Not my server. I’ve contacted the host, but they’re not there right now…
Just tried to do it via SSH, but I’m not root… not allowed too do so.

Just created a brand new project that should simply return “Hello World” and that fails with 504 Gateway Time-out also :frowning:

Something’s borked!

Can I just double check, the permissions on the actual web app should be 755?

Okay - so it’s something in Xojo, I went back to 2014r1.1 and the test application now works!

2015r1 does the trick, my app didn’t like running in 2014r1.1 or 2016rx - but now I’m back up and running…

Obviously something changed that my host doesn’t like. I’ll have to use 2015 until they can figure it out.

Did you build the same 32 or 64 bit in 2014r1.1?

Yes, I did. It’s all 32-Bit still at the moment.

Strange that it won’t work wile it did work.
Did you perhaps had a .htaccess that was overwritten ?

Boy, I can’t think of anything off the top of my head.

Those two errors you cited are typically from an app that’s hung or so busy that it can’t respond fast enough. Do you have the ability to see how much CPU your app is consuming?

When I used “ps -ef -f” it showed 00:00:00 CPU time.

Because of my bad planning and I simply overwrote the original app with the new one, I’ve devised a update protocol that I must follow in the future, at least it should prevent my from borking my system without testing it on the actual server first!!!

This also means that I’m now in the position to try to figure out why the hello world program doesn’t run, if I can get enough information from the server.

Try running an app with ldd. It should give you a list of dependencies and whether or not they’re available.