Until now i liked XOJO...I hope to like it again

I was coding some new nice code to an existing project.
When I tried to open the project next time, this error code was shown:

The project manifest is missing required elements. This project may not have loaded as expected.
One or more items (controls, properties, events etc.) are no longer supported in this version of Xojo. Saving will remove these items.

And then, an empty project is loaded…

I did not update Xojo or changing any settings…

Anyone had the same problem and maybe found a solution?

Thank you, Rolf.

What OS, what version of Xojo? Have you downloaded another version of Xojo recently (without intending to use it)?

Hi Tim

I am running Xojo 2022 release 2,
it’s still the version that is shown in the about in other projects, other still running projects.
I think i didn’t download anything new.

Hmm. Have you a backup of the project?

I have :slight_smile: but without the new code…

Windows ?

Refresh the folder contents in that case.

Check out the videos on how to use SVN or Git. Even using xml with external items is better than using a single project file. Version control will save your behind in such situations EVERY TIME.

Hi Beatrix,

Windows 10, yes.

But there is no option to refresh the folder contents.
Version control i can’t find too…

I do not have a Windows machine to make a screen shot, but there is something; look carefully the screen.
or F5 will do the trick.

maybe the file gone broken at save into network folder?
if you save the project for version control systems (xml/text) you could use locally “GitHub Desktop” app in future.

I saved it locally only.
And I have save to binary only :frowning:

binary is usually fine and fast.
have you compared the byte size of binary file with your backup? should be more or less equal.

have you reorder, moved, deleted things in the project struct?
there was xojo version’s which break the project and make it unusable.

"in this version of Xojo"
this message is odd, are you sure there is only one version on your hd?
have you open the binary project in file explorer by double click or from ide at the time you continue?

Dear Markus

The binary size is a little bit more, because i added some code.
I had copied some properties and methods from a different project before saving…
When i am opening this project or an older, working one, everytime Xojo release 2022 release 2 is showed in the about.

Well, which screen then? F5 i tried on folder and file, but nothing happened…

In the explorer, where your file resides.

I get that six months ago; I made a search in this forum for Emile Refresh Windows and found the entry where I asked for help.

NB: I do not tried F5 (Then), I only clicked in the icon (the rotated arrow) and the project with my changes appeared.


I tried both, always the same bad result…


Thank you very much, but it doesn’t work for me.


Are-you sure this is the file you modified (can it be saved elsewhere ?)

Well, if i was not so lazy in programming new code again, i wouldn’t have posted here maybe.
But there is a bad feeling now when i save a project and never know if i am able to open it again…

Well, I am only saving on my HD C: and the new file is 21 kBytes bigger than the version before, because I added some code.