Universal Binary does not work in the MAS

I tried to upload an universal binary, after signing it with App Wrapper 4.

Everything went smoothly with Transporter, but the build never became available in the MAS.

Perhaps they are not yet ready there. I have not seen anything about universal binaries from Apple anyway.

Several apps are already available on the AppStore as Universal (ForkLift to name one).
So it should work.

Proof is in the pudding. It does not work for me.

Has anybody else tried this yet ?

For the last week or so (maybe even longer), Apple have been having troubles with their submission systems.


I have uploaded a universal binary and after about 3 hours it showed up in iTunes Connect.
So it’s working.


So your build is working :smiley:

Perhaps I was impatient, and did not wait several hours…

Thank you for sharing.

A bunch of Apple developer services have been slow or undergoing maintenance in the past few days. Everything is green now if you check: https://developer.apple.com/system-status/

1 Like

Thanks to Sam Rowlands App Wrapper 4, I was able to sign the universal build for my latest app. Then I sent it to the MAS with Transporter, and it is currently awaiting review :slight_smile: