Unable to run Windows application on Vista

When I try to run an application on Vista, I get the following error messages.

“This application has failed to start because MSVCR100.dll was not found. Re-installing the application may fix this problem”.

“Runtime Error”
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out) can’t find plugin method TextRange.Constuctor()”

and some others similar to the second message, then finally Xojo crashes with a “PluginControlExports.cpp(41)” condition “loadedctl”…

I’m presuming this is down to a plugin?

I seem to remember that missing dlls from plugins give this error message.

You seem to be missing the dll, which is also going to cause other issues. I believe that this dll is considered a system file. To figure whether there are system files missing, this link may help.

…and if all else fails, you can obtain the dll here. This other link may be of interest, although it is not an official Microsoft link. Use with caution as always.

Thanks guys, I ran the app and rebooted the PC, still get the same error. I guess I may need to re-install Windows :frowning:

Rebuilding Windows won’t fix the problem - when I build a certain app on Windows, that MSVCR100.dll file is created via Xojo. When I build the same app for Windows, but on the Mac MSVCR100.dll is missing. I have had to include it as a CopyFile and now everybody is OK.

Hi Sam,

Not sure if this will help - I have seen this error on some vista computer that have not been updated in a long time. Check for ‘Windows Updates’ and update the critical ones to see if this helps. The good news is that performing updates won’t make it worse :slight_smile:

It sounds like your project is using this plugin: https://github.com/xojo/TextInputCanvas that was compiled with an older version of Visual Studio. You can either:

  1. Compile that project with a newer version of Visual Studio that uses the newer msvcr120.dll (that 2014r1 built apps will include)
  2. Modify the project to statically link in the MS runtime, then you can use any version of Visual Studio to build
  3. Include the necessary msvcr100.dll and msvcp100.dll files in your Libs folder. Those files can be found by downloading it here , as was mentioned by Louis above.

HI Guys,
Thanks for the advice.

AFAIK, my client is using the TextInputCanvas but doesn’t compile it themselves, so I’ll go down the route of auto including it in the libs folder. Can this be done with a build script?

Just checked. Copy File build step, Destination App Parent Folder, subdirectory Libs :slight_smile:

Confused. I’m getting this error too now.
I have an app that I can build and nobody is having trouble running, but when I run it in a VM with a fresh installation of Win7, it complains.

Same files, same build.