Unable to pre-test app for MAS

Hello,
before uploading my apps to Mas, I usually test them, following this routine:

  1. I wrap the app with AppWrapper and install it on my machine, without launching it
  2. in App Store Connect I add a new instance and fill all the METAs.
  3. I launch the newly installed app
  4. after a few seconds, I get prompted to enter tester-login and pw
  5. after a few seconds the app appears.

The last time I followed this procedure was November 2020, and as usual it worked.

Now, following the same procedure, after installing the app and filling the METAs, when I launch the app, I do not get any prompt, but a message shows up saying that the app is corrupted and to download it from the Store.

At first I thought the problem was related to the ‘AppStoreReceipt’ code (by Sam Rowlands) in my app, but that would mean that between last Nov and now Apple has changed the way they deal with MAS-receipts. It could be. By the way, what changed from my side was that my MBP now runs BigSur (and I’m building with Xojo 2021v3).

But I thing that the reason is that Apple has changed the “Sandbox Tester” procedure in App Store Connect. Moreover, in App Store Connect, I noticed the TestFlight tab: I selected it and tried entering my “testers” data, but I cannot figure out how I can test my app without uploading it. See screenshot below [No Builrds Available]. Something I never did before. Besides, I guess the TestFlight is intended for iPhone/iPad, while I only upload Desktop apps.

I’d appreciate if somebody could be so kind and give me some clear suggestion how to proceed.
BTW, what about removing from the app the appStoreReceipt code?

I believe you need to upload the app using Transporter

Your testers will then be able to download the app using TestFlight (for Mac)

Before uploading with Transporter, I do not use testers, I myself only want to test it.
So, from what you say, I should upload it to the Store without starting the Review Process and download it using TestFlight. Right?

Yes!
That’s what I usually do with my iOS apps before sending them for review process.

Since Apple released TestFlight for Mac, I believe it is the new standard for testing Mac apps.

Fine. I’ll see what happens.
Thank you.

At the end of the uploading process Transporter issued this warning:

In fact, Status in TestFlight tells “No builds available”.

And I do not know what is this “missing provisioning profile” that should be linked to the main bundle.
Fog!

Edit: besides, TestFlight says that “Test iPhone and iPad Apps on Apple Silicon Macs”.
Yet my MBP is not a Silicon one…

  1. First, move the application to the “Applications” folder and try again.
  2. You need to ensure your test user over at developer.apple.com is configured, not the App Store settings. Confusing I know, I’ll dig our the correct link tomorrow.
  3. I need to update the next prerelease of App Wrapper (as the current one has expired). It adds support for “Provision Profiles” so you can use TestFlight, however for some customers, it means they can no longer test their app store apps on their local machines. I’ve been working with Apple over this and so far have not found a solution that allows certain profiles and receipt verification to take place locally, they appear to need to be tested separately, or tested via Apple’s TestFlight process.

This warning about missing provisioning profiles is send since Testflight for Mac left its beta status. I did ignore it, as I don’t want to use testflight.

In the last three weeks Apple changed the behaviour of testing apps for MAS - on 7. Nov. I was able to test an app before submitting to review using the test profile from my developer account, but on this weekend the test ended up in “App is corrupted…”. The app was reviewed and accepted, but it looks like we have to use those provisioning profiles on a Mac, too.

@Sam_Rowlands - would be fine if AppWrapper can help with those profiles, too.

Yes, it is there.
Then I uploded the pkg to MAS
And Transporter Warning still came up (bundle lacking provisional profile)
And in TestFlight, still “no builds available”

“Confusing I know, I’ll dig our the correct link tomorrow.”
Thanks.

By the way, for this testflight thing, does one need, for desktop apps, to get the iOS Certificates too? I never downloaded them since I build Desktop apps only.

Meanwhile, since at this stage (uploading to MAS) I’m supposed to be the only one to use TestFlight, I wonder if I really need to do such testing.
That is, to start the Review process avoiding TestFlight.
Yep, it sounds like the fox not being able to get the grapes and saying “Nondum matura est”.

So they changed the place to configure “Sandbox Testers” since I last configured an account. It is now at the following link. Accounts created here should only be used for testing the application on a local machine, if you can even get it to run :frowning:

it is now here https://appstoreconnect.apple.com/access/testers

The prerelease can embed and test Provision Profiles to make sure that you’re using the correct one and not using any entitlements that are not allowed.

I’ve delayed the release of App Wrapper 4.4 because of problems testing App Store apps with some profiles and receipt validation, I’d written some new help, but then I got enough reports from Monterey users where help doesn’t work them, that I’ve now written my own help system :frowning:

Yes, I had found it, but for some reason I was not able to have things work.
I put myself at rest and forget about flighttests.

This was actually my main concern when I started this topic: since testing my app (with receipt validation) in the old way brings up a message saying that the app is corrupt etc. etc., my fear is: what happens to customers downloading the app from the Store?
Will they get the same message or will the old receipt code work OK?

Thank you again for the time you give us all.

1 Like

Absolutely, I have the same fear. I am told that as long as it works for “TestFlight” testers and the App Store gate keepers, it should work for customers.

It should just work, but if they get the same message, re-downloading it doesn’t help and there’s so little information to glean when it fails, that it makes it hard to trap in the real world, which is why being able to test it locally is so important.

Not a problem, I just hope that I can make it all work, because I do not like the idea of losing the ability to test my apps before I release them (maybe as Apple expects Apple’s paying customers to be QA agents, they think we all operate in this way).

I’ll wait a few days or week more, and then see if anything gets clearer.

1 Like