Unable to launch web app

I have uploaded a test web app to a Linux apache server.
(1) If I upload all of the Xojo-created files (including .htaccess file), the server returns a “500 Internal Server Error”.

(2) The server host admin guys (Easily.co.uk) told me to delete the .htaccess file. In this configuration, the server returns: “Unable to launch application ‘Atest’ on port 12473”

(I also tried the modified version of .htaccess with “AddHandler cgi-script .cgi” added in first line - but same result as (1) above.)

App was compiled with Xojo 2013 r4.1 as a cgi linux app. The app just consists of a main window with a pushbutton that raises a MsgBox for testing purposes.

Is it me, or them?!!

The url in question is:-

Any ideas will be gratefully received.

This seems like shared hosting. That’s not likely to work. You really want a Virtual Private Server (VPS).

Or wait for 1-click deployment with Xojo Cloud, which is coming soon.

Yeah, thanks Paul, I was rather thinking that might be the case… I was really just looking for a temporary solution for testing / demonstrating, prior to committing my customer to the cost of a VPS hosting. Will be interesting to see how the Xojo Cloud pans out :wink:

For testing or demoing, maybe you can get away with running a standalone web app on your own machine and using something like dyndns.org to map a URL to it.

Ah, good thinking! Thanks for the thought.

I built a Standalone Windows build, set Port to 8080, and ran the exe file locally.

I then opened a browser, and browsed to my PC’s IIS address ( - and my app started up fine, but…
One of my own error dialogues pops up to say “Database file not found.” So this suggests that the hard coded path to the SQlite file is not working right??
If I run the app directly from the IDE it all works perfectly.

What am I doing wrong?

I have several web apps running on Godaddy shared hosting accounts and they work flawlessly. The binary and the cgi script that launches the binary need to be readable and executable by all. I recently ran into a problem where one of my staff put a rewrite directive in the webroot htaccess file that tried to rewrite cgi requests, and that crashed a web app, so I suspect the OP’s problem is more likely a permissions problem or a configuration problem with an htaccess file.

[quote=62535:@Tony Davies]If I run the app directly from the IDE it all works perfectly.

What am I doing wrong?[/quote]
Your code should have error checking to tell you more information. What is the path it is looking at? Are you sure the DB exists there? Just because the path works when run from the IDE does not mean the same path works from a built app.

Yes Paul, you are right. I expanded my error checking, and had the DB path display in the dialogue. I discovered that, having ported the app from an earlier Desktop version, the hard coded path was a Windows disk path. For Web app we need paths in the form of relative URL’s. Once corrected, my app now runs properly and can be run from any browser on network - excellent!

Also, big thanks to all who have contributed to this thread. The original issue of the cgi app not running on the Easily server, is indeed due to it being a shared host, upon which Execute permissions cannot be set for any of my app files. It will require a VPS in due course.

For now, all is good - Xojo is King!!

It’s odd that you can’t set permissions on your shared hosting account. That’s a pretty basic feature. I doubt that you need a VPS to solve that problem, just a better hosting account.