Unable to launch application

I am trying to run an sample webapp in my server and after some set in the server I’m getting
“Unable to launch application ‘MyApplication’ on port 61052”

The app was compiled to linux and all the files and folders are CMD 755 in cgi-bin folder


Miguel Laranjeira

Have you tried running the app directly from the command line? This would tell you if there are any missing libraries ( and the result will help others narrow it down)

Thank for the reply,
Is there any reference to setup a server to work with xojo?
It was supose to be simple, no?

Hey @Miguel Laranjeira - I think you’ll find that there are so many variety of webhosts out there where xojo can’t give a solid step by step example on how to set up for each and every one. It may turn out that your current hosting provider doesn’t support it… or it doesn’t have the right libs installed…or you’re on a shared hosting provider… so many variables. The Xojo Docs do give some trouble shooting advice required for Web Apps -

You can try to search the old forums as well maybe narrow the focus on the hosting provider you are with - Old forum search results you may want to check out this article on the new xojo - Xojo Fourm to see who others are using for their webapps.

There must be a guide, step by step, or something like that.
Ok I tried in 4 diferent servers and all have the same problem :
“Unable to launch application ‘app name’ on port 37649”

It is only me with this problem?

There is no step-by-step guide as there are far too many web server configurations to consider. Here are some topics for reference with some troubleshooting tips:

If you’re on Linux, try launching it with strace, e.g.:

strace ./MyApp --port=3000

This will give you lots of information about what the app tries to do and may heklp you figure out exactly where the problem is.

I’ve got the same error:

Unable to launch application ‘TaskManager’ on port 43960. Any advice?