Unable to launch application 'test' on port 39346

Unable to launch application ‘test’ on port 39346

I have created a cgi web app in real studio. Locally it’s running fine but when I upload it to my cgi folder on my server it refuses to run and give the above error.

Files are uploaded in binary mode, proper permissions are set but still the same error.

Server is on Linux and so the project is complied for Linux.

Plz help me to run the app.

I am very desperate.

Is it a 64bit Linux server?
If it is you might need ia32 libs.

That message can mean a lot of things :wink:

What permissions did you use on the files?

Write and execute

How Dow I check if its 32 bit or 64 bit

Plz check the URL


please help me I have no clue how to make this work. Tried everything I could

In the servers Terminal, type: uname -a
x86_64 GNU/Linux indicates that you’ve got a 64bit Linux kernel running.
If you use see i386/i486/i586/i686 it is a 32 bit kernel.

What do you get when running that command?

It’s a free server I gave the link above. Could you plz check the link. I really appreciate your help sir

Sir I am not in my office I am at home on my mobile. I can only check that tomorrow. Sir as I told you it’s a free server in host-ed.me. Could you plz do me a favour plz make an account and try it for me.

I cannot find any info in their site about the server hardware/software they use.
Contact their support and ask if it meets the requirements for built Linux apps :slight_smile:

x86-based Linux distributions with GTK+ 2.8 (or higher)

And if its a 64bit server, ask if ia32 libs are installed :slight_smile:

Lets start there!

And double check the permissions.
.cgi = 755
.cfg = 755
app itself = 755
The rest should suffice with 644 if I remember correctly. Personally I use stand alone deployments :slight_smile:

Sir that’s what I gave for file permissions but I gave the rest of the files 755 also still not working. Sir do you know of any other free hosting server where I can run and test my cgi scripts. I am having a lot of pressure for my manager.

Sir I have shown my manger the script is working fine locally but he wants me to show it online. I can’t pay for paid server. Plz help sir

Contact Matthew Combatti here on the forums.
I believe he’s got a server for free for developer use over at xojodevspot.com. I don’t know if he still does but it’s worth a try :slight_smile:
Matthews Profile

Or if your manager has a server on his own you could build a stand alone app and run it there.
Stand alone apps are way easier to deploy but the can’t be run on those free public servers. They require a VPS or similar.

ok sir i will try to contact him

Have you opened the firewall ports (Incoming and outcoming) for your firewall? In this case is port 39346? I use CSF and there are options for TCP and UDP ports in /etc/csf/csf.conf.

If you SSH your server/VPS you can launch it locally. If it works locally it should be a firewall settings problem.

Hope it helps.

[quote=12067:@Amando Blasco]Have you opened the firewall ports (Incoming and outcoming) for your firewall? In this case is port 39346? I use CSF and there are options for TCP and UDP ports in /etc/csf/csf.conf.
On a CGI app those ports dont have to be opened in the firewall. Those ports are used on the server itself for the CGI script to communicate with the app instance. It’s accessed on the same port as the regular web server.
(correct me here if I’m wrong bu this is my understanding)