Unable to launch application - now with undebugable issues!

I am no novice to linux system admin and unless I have lost my marbles and missed the obvious I am stumped.

I usually deploy apps in AWS, have done for years without issue.
Now I try and run a turnkeylinux LAMP stack on virtualbox and get the dreaded “Unable to launch application” error.
I have seen this many times and have simply refreshed but no it persists.

I am running Debian Weazy with all packages up to date
I have multiarch running with i386 compatibility
I have checked the permissions, they are fine.

When I check the apache logs I get

[error] [client xxx.xxx.xxx.xxx] Can't exec "/var/www/cgi-bin/physioware": No such file or directory at /var/www/cgi-bin/physioware.cgi line 173.

naturally one jumps to the line of code in question highlighted in bold italics

[code]sub launch {
my ($port) = @_;

    if ($is_windows == 1) {
            my $process;
            Win32::Process::Create($process, script_directory() . "/" . $app_name,"--port=".$port,0,$process_type,".") || return 0;
    } else {
            my @args = ("$app_path","--port=$port");
            [b][i]system(@args) == 0 or return 0;[/i][/b]

    return 1;


And when I check that /var/www/cgi-bin/physioware.cgi exists, sure enough it does.

What obvious signs am I missing?

Actually, the error is saying that the application itself is missing. It would be in the same directory, and simpy named physioware.

Its all in there…

root@physioware ~# ls -la /var/www/cgi-bin/ total 3648 drwxrwxrwx 4 root root 4096 Feb 10 03:48 . drwxrwxrwx 3 root root 4096 Feb 9 11:34 .. -rwxrwxrwx 1 root root 86 Feb 10 03:48 .htaccess drwxrwxrwx 3 root root 4096 Feb 10 03:48 Resources -rwxrwxrwx 1 root root 58 Feb 10 03:49 config.cfg -rwxrwxrwx 1 root root 3700957 Feb 10 03:48 physioware drwxrwxrwx 2 root root 4096 Feb 10 03:48 physioware Libs -rwxrwxrwx 1 root root 6677 Feb 10 03:48 physioware.cgi

I thought it was the server build so I tried it on AWS but I get the same problem.

The only thing that different is I coded a login mechanism for authentication, recompiled and uploaded.

OK so for anyone trying to get this working, please note;

I am using turnkey linux LAMP stack on virtual box - this may not work on your distro.

I was running through different packages and rebuilding the server to determine what works and what doesn’t.

Found this article on MultiArch and interestingly under the “android” section at the bottom it gave this recomendation.

aptitude install libstdc++6:i386 libgcc1:i386 zlib1g:i386 libncurses5:i386

I did this and problem solved. Not sure which package did it but will test further later!
That took 48 hours, far far too long for my liking!

Ah, sorry for the confusion. Apps built with Xojo are currently 32-bit. You certainly would have needed the first two libraries.