Unable to deploy to cloud server


problem which has to be solved ASAP is, that I can’t deploy to cloud server anymore after yesterday’s xojo license renewal.
Aside having installed XOJO 2017r1.1 nothing was changed.

What works:

  • Webapp on cloud server can be accessed from several PCs and smartphones
  • Even posting data from embedded system via Specialurl into MySQL-DB works as before
  • Apps are listed at account / cloud / list apps (was not the case yesterday)
  • MySQL-DB on cloud server can be accessed by MySQL workbench
  • Running the app locally via “run”

What does NOT work:

  • Deploy to cloud: "An error occured while communicating with the Xojo servers)
  • Build settings / Server: No server selectable with “refresh”
  • Edit / Options / Proxy / Test connection says: Connection failed, no access to master server
  • Help / My account: “There was an error displaying your account control panel”

Do you have any ideas?



Hi David - I just replied to your email about this.

Hi Jason, thanks for fast response now.
Sure I tried to restart server several times, makes no difference

Ok - we’re looking into it now.

Hi David - this should be working now. Sorry about that.

Ok, I get the London server now in build settings and deployment is starting.
But it soon cancels with “…because your permission to do so can not be established”

Ok. What if you try again?

Yes, seems to work.
Thanks for your support!!!
Anything I can take care of to avoid same problems in future?

Great! You’re welcome and thanks for your patience.

No, nothing that you can do - we just had a few issues to clear up on this side.