Trying to deploy Xojo's CGI Test app on my Bluehost server

I know I have done this many years ago and don’t remember it being so difficult - however this is the first time on Bluehost. I thought I would try to use Dojo’s test app that I found here…Deployment overview — Xojo documentation - sort of ensures that everything is “built” correctly. I have created a sub domain on my host call mydash - there is folder under the HTML directory called mydash as well. I used Filezilla to copy the contents of the 32bit CGI app to the CGI-BIN under mydash…I even changed the .CGI file’s permissions to 755 as I remember back from the past. So when I go to execute at http:// - I get the notorious error shown below.

I checked to be sure Bluehost does allow CGI Scripts and they do so I am at a loss. I even copied the above steps to my main domain CGI-BIN folder(since deleted) to see if it was subdomain setup error…I know there are easier options vie Xcloud but now I am just challenged to get it all figured out.

Can anyone suggest what to do next? This seems so trivial. Thanks in advance.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Apache Server at Port 80

Are you sure your server supports 32 bit, out of the box?

Nope -assumptions made…should I try 64bit?

Sometime ago I had the same problem on a Linux server running Apache: I solved it deleting the .htaccess file.

It’s ages ago since it did it. But seem to remember that some additional libs had to be instilled by the host provider for me to run 32bit.

If you have command-line access to the app, you can check for dependencies using ldd by going to the cgi folder and typing:

ldd testcgi 

Bummer…tried removing .htaccess, loaded 64bit flavor(with and without .htaccess) - to no avail. I even got Bluehost support involved to help last night, So far no progress. I am out of ideas at the moment. Off to find the server error logs. oh yea…no command line access that I know about.

Shared environments are not the best places to set such things up. Better to set your own virtual machine with full access in places like Digital Ocean, Linode or Amazon Lightsail.

Found server error log…at least I know why 64bit won’t run…GLIBC_2.14’ not found - Webapp was compiled against higher version of this library that my server isn’t running(currently)…Since I found the error log, I think I will go back and see what errors the 32 bit is throwing…will also, at some point introduce the conversation with Bluehost.