The operation couldn’t be completed. : no identity found

is there a general solution to the problem during build for ios?
The operation couldn’t be completed. : no identity found

I saw here that several people had the same problem, and they solved the problem in different ways.

For me neither new certificates or Certificate with CSR or new profiles nor reinstalling Xcode or xojo helped.


it works with Intel Mac, but not with M1 Mac.

We fixed something like this in 2021r3.1, but do me a favor, on your M1 Mac, do you have Finder’s option to always show file extensions turned on?

yes, it’s on

I forgot to mention I’m trying to build it for iOS.

Try turning it off and see if that helps.

I tried but unfortunately it didn’t help

The only other thing I can suggest is to look at my blog post about signing from the Fall:

ok, thanks problem solved.

  1. There were invalid certificates in my keychain that were missing private keys (I had overlooked them, they were not visible under “my certificates”). My newly created certificates and profiles were only recognized after I removed them.

  2. created app-id from developer site, bundle identifier and App name must match.

thank you

1 Like