"The application xyz is not open anymore"

In App.Open there is a Timer subclass started. It’s from the olden times (Charles Yeomans). It’s like an AddHandler for a timer. The timer is started and then it’s doing the check. Working that way since 15-Oct-2012.

1 Like

Is it a console app or desktop app?


1 Like

You encounter a lot of unexplained issues.

I think you’re going to need log data from the customers machine (good luck with that).

Need to know why is no longer running? Exiting or being terminated? If it is being terminated, by what and why.

I did find the following article, which basically says, don’t know, but you need to force quit the app to clear the message. Feels like a zombie process to me.

The app is still running. The user already tried to reset the app. The design of the app is unchanged since 2012.

It appears that is the problem, part of the OS thinks it’s dead, while part of the OS thinks it is alive.

No result from that path?

I’d start by asking him/her about the list of running processes. Since the error looks to be about a half-open/half-closed app, it’d be good to know if the OS sees both apps (the main one and the helper) as running.

It can take another form too. When I got this error about the Finder, trust me, I tried force-quitting by all means, finding sub-processes to kill them too, etc. Only duplicating the app and launching the copy worked (the original one would still not launch); restarting the computer was the only fix I got (and I tried lengthly, by curiosity).

This is the key: the app is half-running when you get this error. Some parts of the OS think it is, some don’t.
I’d list at least these items of your app, which may or may not exist/run at the same time of the error:
UI (windows you see from the app)
an entry in the ps terminal command
an entry in the processes list (using declares; may not return the same list as the ps command)
a dot in the Dock under the icon; an entry in the app switcher

Perhaps knowing which of them are existing and which aren’t could lead to more understanding about this bug.

It seems that this app is in a “non-responding” state when this happens. Could it be because somerhing changed in the way apple handles running in the background (e.g. Deactivated app) for a certain amount of time?

I’ve had that same issue… and similar usage where I have a helper app that makes sure that the primary app is alive and running, and if not it relaunches it. Haven’t figured out what causes it.


If you use MBS plugins, you could try using NSProcessInfoActivityMBS to disable app nap.


I’m not sure if that is what’s actually going on here, but it’s worth a shot.

1 Like