TextField and Time Mask

Feels like one of those days where I am overly stupid, but I don’t get an idea what I am doing wrong:
When I assign a mask ”99:99" to a textfield, it should allow time entries, right? So on my German system where I have “:” as time separator too shouldn’t I be able to enter a time like 21:22?
If I try, the entry jump to 2121.10.01, 18: after I entered 21. Looks more like a date.
I can make it work by escaping the time separator, but this way it’s not localized anymore, with a Mask ”99\:99".

Sure, I could make the mask a computed property, but how can I make this work without workaraounds?


I can confirm that behaviour on macOS Sierra. Neither works ##:##. Have you tried it on Windows?

Thanks, Alex! So you mean this is a bug and not me being too stupid? I struggled with masks of this type right from the start but thought I had missed something. No, I didn’t try Windows yet. Will do soon.

It is a bug. It runs ok on Windows and Linux. Thanks again, Alex! I really thought it was me!

Due to date/time format issues I have standardized on a graphical input that is just a modal dialog where the use presses buttons or options from popup menus. It is just too hard to get the user to enter data correctly for dates/times so I limit the choice.

You mean an older bug report already exists? I mostly miss them when I search for duplicate, it seems. Do you know its id?
I chose to escape the colon, which creates a bit more error handling.