Textarea sometimes has SelTextFont as Font Bug (Not)

I have a new XOJO bug apparently.
One of the textareas on a window has the displayed font as Lucida Grande and this should not be for several reasons.

It is the SelTextFont.

I have 0 or NO SelText.

I have Times New Roman assigned to the TextAreas on this Window as TextFont and SelTextFont.

It also appears as only 1 of 6 textareas.

I have rebooted my Laptop. I also found in XOJO preferences under Build the Clear and have cleared.

Nowhere do use Lucida Grande


This could in fact be the mac doing font substitution. If you use a glyph that is not present in the current font then the mac will fall back to one that does have it and may fall all the way back to the system default font to display that glyph.

Thanks. That was my first thought, until it didn’t change back to Times New Roman.
Forgot to mention that weirdness.

It’s also in this area usually only ascii. One example is changing from [quote]Adjective?(Descriptive?Verb)[/quote] to [quote]Adjective[/quote]

If it only happens in 1 out of 6 textareas, could it be something corrupt there? (I don’t know). Have you tried duplicate one of the working textareas and replace the one that doesn’t work?

Can you create a sample project that replicate the behavior?

I really would like to change this from a bug but…
The six areas go through the same code.
About a project, I cannot even figure out when it happens. It happens sometime after the last return to showing the window.
Like after activate.

Thanks I had not thought of that. I try it later

Corrupted text area. Almost.
It worked until I deleted some text. Cutting text was fine. Deleting not fine

I should have looked at an rtf file with a character recently added. It’s called “Hyphen Bullet” and instead of Times font, it was Lucida. The character is [quote]?[/quote]
After replacing the TextArea it would revert back to Times.