Textarea Font Problems

I am using 2012r2 on Windows and for some years have been having a problem getting the font I want to use to display. I am using a Unicode font for the Korean language and it defaults to some system font. The code I use is simple

textarea1.textfont = font

font is set to the number of the font in the computer’s list and then the name is gotten, etc.\
For some time I’ve been getting some system font, and now it comes something vertical.
I thought textarea1.StyledText.Font would work but it doesn’t and since the font is applied to the whole textarea, it shouldn’t matter, but something does.
What could be wrong?

You want to use SELTEXTFONT

in conjunction with SELSTART and SELLENGTH

a little research in the Lang Ref concerning TextArea goes a LONG way

font is set to the number of the font
I think font number have been deprecated 20 years ago or so (too many different fonts to deal with a 16 bits integer) ?

i’m sorry for not looking at the manual first before responding. I’m hungry and want my b’fast.
2 Questions

  1. If I use seltextfont can I set it to the property of the area? That’s what I had before. I assume not, and it’s more like an .rtf file.
  2. This font number is, as I recall from yesterday, still the way in textencoding the way to find the font. Is there another way of getting and keeping the font as a property.

Font is set by using the NAME of the FONT

if you read the LR, you will find you can set the TEXT of a selected area (ie. replace words or characters) using SELTEXT
change the color using SELTEXTCOLOR
change the fontsize using SELTEXTSIZE
change the attributes using SELBOLD, SELITALIC and SELUNDERLINE

When I researched all the code I had written, I did use seltext and the other parts. It’s part of the graphics ‘function’.
So, that’s what I do. For the separate controls Seltextfont is set to the correct font as is textfont.
Before I set the text’s font, the font is system. No surprise.

The graphics font for the window itself though is empty, and I wonder if that is how the system font is ‘leaking’ in.

Another problem is apparently textdirection isn’t supported on my computer, or it’s hidden, since there’s no attribute in the window.graphics, which means it goes to unknown, which might be what I’m experiencing. Also the funky direction only happens with the Korean text. The rest has normal direction. And korean direction is not how it appears in MS’s Wordpad.

You are correct about setting it with the name, but if you look up Font in the L.R. you will find an example of using index to verify the font’s existence on the computer. You apparently use fontcount also. If it isn’t available to the program it’s possible that might be why I’m getting a different font. I don’t know how to test about NOT availability since the font shows up in the list of fonts.

Any thoughts about why my Korean font is going screwy.
When I paste it in here it comes correct. Before you had to turn your head sideways and it’d read down not the left to right you see.
[?? ??? ??];
If I paste it into MS Word as text it goes correct, but keeping ‘style’ it goes screwy, but what the other style is I can’t find it.

I upgraded to XOJO and it does the same thing. I tried to paste an image and it refused, which is good but bad for the forum. If you’d like a copy I have one. It isn’t good for the Korean font. The analysis was not a surprise except for one change of paint from graphics. Won’t be near this computer for a few days, so if anyone has an insight, It’d be nice.

I tried running the .exe on an earlier version of windows and the Korean font problem doesn’t happen, so it is Windows7 or some version of it. This seems to be therefore a bug. IF this is a bug How do I declare it? I use ‘graphics’ ‘textarea’ and ‘Windows7’ and ‘textencoding’