Text Area: Single Line

Mac: Mohave
Xojo 2019 Release 3.1

From the documentation:

In the IDE, I do not see any option to turn off Multiline.

If I do it in code:

taRecentTop.MultiLine = False \\\\ where taRecentTop is a TextArea in the window

It does not have any effect that I can discern.

So I am confused as to what is even meant by a “non-multiline” TextArea

The old property called “multiline” doesnt seem to have a new counterpart in the inspector
And it appears that this has to be set at design time (or the multiline property no longer works in 2019r3.1) as the code you posted basically behaves in 2019r1.1

The online documentation for TextArea says [quote]For single-line text fields, use the TextField control.[/quote]
I guess they disabled the MultiLine property in TextArea and removed it from the Inspector.