Take HTMLViewer out of IE Compatibility Mode

I cannot access the webpage that I need to because the HTMLViewer is in IE Compatibility Mode. This only happens on Windows (works fine on Mac). I have tried changing the UserAgent property of the HTMLViewer but that did not take it out of this mode (and also happened to crash the app whenever I tried logging in to websites. See https://forum.xojo.com/18986-htmlviewer-crashes-app-when-logging-in-to-websites ).

Any solutions (other than editing the registry… my work intranet doesn’t allow registry changes and I’m not willing to get around the admin privileges with the usual tools)?

I only know about the registry.

If you have control over the page being shown, you can add the following tag to the head tag:

<meta http-equiv="X-UA-Compatible" content="IE=edge" /> 

I have no control over page content. Perhaps this is a bug that needs to be addressed by Xojo.

I went ahead and circumvented the admin privileges and adjusted the registry. The app works now, but for those who have the issue and actually want to distribute something (my app is for one machine, for one purpose), they’ll need a less hackier fix.

NOTE: Adjusting the HKEY_LOCAL_MACHINE keys/values didn’t work for me. I had to create the structure under HKEY_CURRENT_USER for it to work.

Are you unable to use the Webkit renderer on Windows?

While it’d be nice to be able to override the compatibility mode the OLE control doesn’t let us do that