Strange Windows 10 behavior

Nearly everything in Windows is strange to me, but this is really annoying.

I made changes to a project that resides in a Shared Directory/Folder. Then I save the changes.

Once back in the Windows 10 window, I open that project (I closed it before making changes on MacOS) and notices the absence of the changes. I closed the project, and in the explorer I asked for the project modification date: it was hours ago.
Back to the Shared folder on the MacOS side, I checked the Info and see the date… is a minute (or two) ago.

That explains a lot: I wasted hourless to make changes to that project (that worked fine on MacOS, but crashed on Windows or do not behave as expected…

And I do not talked about “how do I set a custom Icon” to a service file on WIndows…
I was able to do that to folders (many clicks away; compare that to how you can do that in MacOS…), but the procedure is unknow to me.

I do not even checked with Google… because the last time I searched something, I fall into so many traps (plainly wrong and/or outdated information).
As an example, search for “How long a file name can be on MacOS”; you can replace MacOS with Ventura.
256 or 512 are bad answers…
Windows answers are bad answers too.

If you drop a temp file next to your project in Shared Directory/Folder on the Mac does it appear in Windows?

I will check once at home (that laptop have a broken monitor).

In the old Windows XP, it was possible to ask for an update (refresh) of the folder display, but I do not saw that in Windows 10 (is it still here ?)

But, if I am really right, this explain why I had multiple troubles using 2015r1 on Windows 10.
Else: I need a serious nap, sleeping a whole week (think that I am retired and do nearly nothing in the whole days, weeks, months…)

Yes right click Refresh

Mmmm nap gooood

Care to explain where it is ?

yes, nap are good unles it is too long; in that case, the night will be long, too long…

In the Explorer window, there’s a button at the right-hand-end of the address bar. Or, according to the tooltip, press F5.

1 Like

Thanks, I will look carefully.

In Explorer right click on the empty space (not on an item), it should be the 4th entry down or you can click this icon at the end of the path.


What’s your workflow? Are you:

  • running the IDE on MacOS, editing & testing your code on macOS
  • running another copy of the IDE on Windows, editing and testing your code on Windows
  • using a Shared Folder (is this SMB sharing under Windows? Or are you using a VM tool such as Parallels or Fusion on the mac?) which holds your code for both IDEs?

Here’s how I do it:

  • use a mac
  • using Parallels or VMWare Fusion to create one (or more Windows VMs)
  • run the IDE on macOS only
  • to test on Windows VMs, use the Remote Debug feature: Remote debugging — Xojo documentation
  • If my app needs a lot of support files, then I do use a Shared Folder (using Parallels or Fusion shared folder feature) to hold the files

I suspect I do as Emile does here.
My Mac has a folder of code and resources (which is on my desktop)
I run Windows 11 in a Parallels VM , and share the Documents, Downloads, and Desktop area.
because I have been bitten hard by it, I do NOT have iCloud synching my documents.

Inside the VM, I can launch Xojo 2015 (Still using it… nothing afterwards does graphics properly…) and open the project from the Mac Desktop, from where it opens and runs fine.
I personally haven’t seen any evidence of lost changes yet, but I maintain a strict filenaming process… each step of the way I change the project file name to todays date.
So if I make some changes, I know that I am opening the thing I saved, with no chance of opening ‘the same old filename’ yet getting an old version.

I do know that Apple’s filing system can take some time to reflect what was saved, moved or deleted these days.
Maybe off-topic, but many times i have run into code issues where I save a file in one method, then try to open it in another, and find it is not ‘there’, unless I wait for (say) 0.5 seconds to access it.

Thank you Julian. I searched the menus, do not found and forget it.

And yes, before the refresh, this is an old copy that is loaded !!! :hot_face:

I installed VirtualBox in a i5 MacBookPro.
Installed Xojo 2015r1 exe,
Moved the project on VirtualBox, using a VirtualBox Shared folder,
Then, made the project works on Windows 10 (it “worked” on MacOS, but will be running on a PC Laptop @ the Charity area).

I use the i5 Xojo 2015r1 mostly for its Language Reference.

I even create another project to report in 3 different windows the .sqlite file contents (Service TABLEs, sqlite_master contents and the client data TABLE contents.
In the Service TABLEs window, I can delete a TABLE and replace it with a fresh one (this allows me to remove duplicates rows / change the TABLE definition in case of error… and these comes so easylly !)

The generated .exe is copied in a MemoryStick, then copied on the target Windows 10 laptop. No unknow developer window is displayed.

BTW: how do I move a .txt file at compile time under Windows ? The MacOS used method do not works there. And this is used to fill a PopupMenu that is mandatory to add / modify a Record.

I think so too Jeff.

What I do not talk about was the thirs screen where the TV is laying on :innocent:.

I must comfess… when I started to made the changes (logo / names), I was thinking it is a simple matter of some hours… and that software was not done to automatically change the Logos / Images / Company names (I’ve made one like that later and it was nice ! Just a matter of Preferences → select the company in a folder and the correct stuff appears o screen !).