Strange URLParameter behavior

I wrote a web app that allows a user to get the model number for an electric submeter by choosing all the parameters. At the end, they can get a data sheet and installation diagram in pdf format. The sales department wants to be able to add a link to every quote that will take the customer directly to the final page of the web app. Sounds simple. Add the model number to the end of the URL as a GET statement and process it with the session.URLParamenter tools in Xojo. I started getting strange values in the debugger. I run the app without any command line options and it works fine the first time when using Firefox. Then I launch Edge and type in

it sort of works, but I haven’t got that part working yet. The problem that’s hampering me now is when I run the debugger again (, Firefox is finding the same URLParameter I had entered in Edge. If I exit Firefox, then run the debugger again, it runs normally. Is this a problem with Windows, Firefox, Edge, Xojo or me?

I am thinking this may be related to the other problem I am having with the WebPage.Opening firing repeadedly after a method that works fine when there is no URLParameter runs.

The live version of the app is at

Do you need to encode the / as %2F ?

1 Like

The slash comes through OK.

It appears to be a Xojo bug in 2022r3.2 as I tried it in 2021r3.1 and did not experience the problem. I’ll file a bug report.

I guess it was a bug in 2021r3.1.

Just for a test I pasted ?model=A4231/E to the URL of this post and after loading the page Chrome shows ?model=A4231%2FE instead

A slash is not allowed in the querystring itself. It must be encoded correctly. This is what EncodeURLComponent is for and DecodeURLComponent. If you manually put a url in a browser, some browsers may fix it automaticly, but don’t expect this to be a xojo issue directly since a slash doesn’t belong after the “?” in a url.