Start Xojo Maximized

Hello everyone,

does anyone know a way how to start Xojo maximized when double-clicking a project file?

Every time I try to open a project like that, Xojo starts as a window (also, toolbar takes its space but buttons are not visible), so everytime I have to maximize and use Ctrl+Shift+T twice to show and then hide the toolbar.


go to: Try Edit -> Options-> [General]


Show Library and Inspector [x] In the Project window

hello Ruben,

that option doesn’t have any effect…

here’s what it looks like when started.

hi Shant… in try with this conditions:

[win7] and [xojo2014 R2.1]

And work fine…

But i remember this problems, when i use Show/Hide toolbar… any time, show blank
Contact with Support

Win7, Xojo 2015R4.1 … I’ve actually seen this happen since the new Xojo IDE came out.

Does anyone else experience this?

Close Xojo down fully, all windows.

Start Xojo, create a new project test1234, maximise it, close xojo down, discard changes.

Double click one of your xoxo_binary_project files.

Works here, all my windows are opening “almost” maximised (ie full screen but not maximised enabled)

Its the best I can do, it doesnt seem to be saving maximised state, just the size of the window :frowning:

Yeah… perhaps a Feedback request is in order? It’d be nice not to maximize the window every time.

For Windows only:

Xojo IDE remembers the Window size and screen location you last exited, but not the Windows state. On the next launch, it re-open to this size and screen location. It does not remember Windows state, i.e. minimized, normal or maximized. Instead it always open normal. Therefore if you last have it maximized and exited, the next launch will be normal with full screen size, not maximized as it should be.

The Windows standard is to remember Windows state (normal or maximized, ignore minimized), windows size and screen location.

Thanks !

[quote=262342:@Shant Khatcherian]Yeah… perhaps a Feedback request is in order? It’d be nice not to maximize the window every time.