Stand alone App on Linux/Pi crashing without any log entry

Hello all,

I am seeing periodic crashing of my web app where it just quits seemingly spontaneously. I know there must be some reason for this, but none of the error handling is capturing the error before or during the crash. Xojo 2017 R1.1. Several different plugins. Normally it runs fine, but some combination of events causes crash.

Can anyone suggest best way to capture whatever it is that is going wrong? Most, if not all methods, in each and every class, have errorhandling like this

** In the method  **
Exception e as RuntimeException
  Dim Flds() As String  = array("EXCEPTION", CurrentMethodName , Cstr( e.Type) )
  Log.AddFields Flds
  Log.LogFileAppend( Log.K_Except_App_Err)

** In a global

Public Function Type(extends e as RuntimeException) as String
  Dim T As Introspection.TypeInfo = Introspection.GetType(e)
  // Dim Logs As New clsLogging
  if T <> nil then
    // Logs.LogFileAppend(T.FullName,1)
    return T.FullName
    //this should never happen...
    return ""
  end if
End Function

** in App unhandled exception

Function UnhandledException(Error As RuntimeException) Handles UnhandledException as Boolean
  Dim Flds() As String = Array("EXCEPTION",  CurrentMethodName ,  CStr( error.Type) + "  Err Msg = " + Error.Message )
  Logs.AddFields Flds
  Logs.LogFileAppend( Logs.K_Except_App_Err )
  Return False
  Exception e As RuntimeException
    System.DebugLog( "Unknown exception in:  AxcysEmbeddedEngine.UnhandledExceptions ")
    // MsgBox("Unknown exception in:  AxcysEmbeddedEngine.UnhandledExceptions  " + e.Type + " .")
    Flds = Array("ERROR", CurrentMethodName ,  CStr( e.Type) )
    Logs.AddFields Flds
    Logs.LogFileAppend( Logs.K_Except_App_Err)
End Function

I am not seeing anything in the “system.debuglog” nor in the my own text file logs.
Any suggestion would be appreciated! Normally work in Windows10, but have to copy all of the files to another computer set up to run Linux only so I can compile this app. For some reason, I cannot compile this particular app for Linux/Pi on my main machine. Xojo tech support was apprised several times beginning Dec 2016, advised in early January to use a Linux machine to compile instead since it worked (and it does just a pain).

Also, I have not yet tried to do remote debugging between the Linux computer and the raspberry pi. The linux machine (mint of GUI) is a bit clunky for me, and so have been reluctant to go that next step, although I think that may be where I have to go.

Again, if anyone has any suggestions I would be very appreciative!

Thanks in advance!

Look in /var/log/kern.log. If the app is outright crashing, the issue will appear there.

just use

cat kern.log | grep appname 

Hi Greg.
That command does not work
cat: kern.log: No such file or directory

you could also look in /var/log/messages or /var/log/syslog

I just pulled records using webmin for Kern.log.

Will pull some from the two you suggested John as well and advise.