Sqlite file type group

file type group (ftg) for SQLite

  1. I am unable to set an icon in the ftg below (crash everytime at .png (or .ico) file drop time.

  2. This ftg works (enable a sqlite selection) only after I set the four question mark characters !!!

M1/Monterey/Xojo 2022r2.1

two hours to be there !

the role and rank I set disappears sometimes during the tests…

Yep. Crashes on Windows, too.

Robin was not able to see the crash.

Feedback case is:

I even made a screen shot and dropped that into the canvas to get a crash. A screen shot does not have alpha (white is transparent); my other test images had transparent areas…

The Xojo Plugin folder was renamed …

I sent the real project (the one I was running yesterday) as is and some images, but the crash was not reproducible.

Tested on Xojo 21r2.1 and 21r3.1
Monterey 12.2.1 (21D62)
MacBook Pro m1 (buy date: 2021-02-20)

I just tested it (again) with 2021r3.1 (demo mode) and…

Can’t find that case


When I uploaded the project (the one I was working on), I set the files as private. This probably makes the case private, not only the files.

Know that yesterday, when back home (no Internet), I fired Xojo (current) created a new project, add a File Type Group, checked the CheckBox to allow file drop in the Icon canvas, and it crashed.

I set the Plugin folder name back to its default (in case it matters, who knows).

All of that took less than a minute to achieve.

Instead of dropping the image on the icon box in the FileType definition, double click on it to open the icon editor and drop the image there.

Hi Dale,

When I do that, Preview is fired. And drag and drop does not works there.
Yes, I can try to use Firefox… But I do not need that feature. I will probably never build this project.

That is my fault; I learned long time ago to stop using feedback. I will try to recall to avoid it. Better: I trashed it, so this will recall me what not do.

After Dale’s suggestion, I tried to drop an image from Firefox, but it does not worked. It simply open the Icon Editor window.

I closed it, tried to drop an image on the FTG Canvas and it does not crash.

To All, Robin included:

I never tell that I got a crash when dropping an image file above the Icon Editor, but above the Canvas; you know, the canvas that is at the right of the Icon word in my first screen shot far above…

At last, I forgot that a click in that Canvas HAVE to be done to show the Icon Editor…

Have a nice day.

Icon Editor above…

I’ve seen a crash when you drop an image but when you drop it on the File Type Group editor directly, when when you click the image panel to get the Icon editor.

File Type Group Editor. The red box marks where you drop to create a crash.

I can’t find the bug report I made about it at the moment.

Yes, that is what I discovered.

What was also problematic was my settings that disappeared when I closed the Editor (back to the Code Editor)…

But I learned the lesson. If someone want to go ahead, feel free to do it.

For your feedback, you can access it if you click in “My Cases” (or something with this meaning).

Yes, I know, but there are 61 of them and I can’t see the wood for the trees.

The last one (that was it in my case(s)…)