SQLite 1000 row limit?!

Hi All,

I’m writing to a SQLite database, and after 1000 rows it isn’t taking any more inserts. There is no error, the insert statement completes successfully but the row just gets swallowed. I also tried from a tool called SQLIte Studio and it’s the same.

If i delete a row, I can then insert one but no more. There’s rowid as primary key and a couple other columns.

Anybody seen anything like this?


Have you tried to switch autocommit off and then commit each time after inserting 200 records or so?

@Oliver Osswald , on insertion of every row I do a BEGIN TRANSACTION then INSERT and then COMMIT. That should have restarted the autocommit, right?

I’ve copied the DB file on another computer, still same - can’t add beyond 1000 rows…


I’ve never seen any limit like that. There must be something else going on.

I’ve done a vacuum, integrity check, renamed the file, removed other tables from it, still can’t add beyond 1000 rows… :frowning:

Okay this will be lame. The button that shows “next page of rows” wasn’t visible in SQLite studio. All the bazillion rows after the 1000 are there on next pages.

Let’s pretend this never happened :slight_smile:

thanks to all!