[Solved] Renderer is trying to add multiple lines at once...

Been working on a console app for several weeks now, and everything has been just fine. Launch RealStudio this afternoon and I can’t do anything with this one particular project as I keep getting the following error:

Runtime Error
Press OK to Continue
Press Cancel to Quit.

Please report what caused this error
along with the information below.

Failure Condition: *ptr != ’
’ && *ptr != ‘\r’
Renderer is trying to add multiple lines at once.

Google’d the error, and seen where people have gotten something similar before for copy & pasting multiple-line text in their labels; however, as a console app… I have no labels. I’ve also (to my knowledge) have not copied and pasted anything. Fortunately, the project loads into the IDE just fine… but I can’t run or build it w/o this error. I’ve removed constants/properties/etc. one-by-one in hoping to find the culprit. I ended up with a blank project when I was done… tried to run/build… same error! It’s only affecting this project. Tried creating a new project and moved my constants/properties/etc. to it (hoping to start fresh) and it ran once, then the same thing happened to it. Anybody have any clues as to what the heck is causing this? Both projects are saved in XML format.

I always do this… send a request for help, then shortly after find the problem.
What happened is I have an IDE script that uses an external console app to handle version control:

propertyvalue(“app.minorversion”) = doshellcommand(“p:\version_control.exe /command:minor_version”)
propertyvalue(“app.bugversion”) = doshellcommand(“p:\version_control.exe /command:bug_version”)
propertyvalue(“app.nonreleaseversion”) = doshellcommand(“p:\version_control\version_control.exe /command:non_release_version”)

Apparently, one (or all) of the returns is including an extra or weird end-of-line. So, my fault… sorry about that. :slight_smile:

BTW, don’t know the proper etiquette for version control; however, I base mine on something similar to:
1.13.0522.13304 (or A.BB.CCCC.DDDDD)
A = major release number
BB = last two digits of the year
CCCC = two-digit month + two-digit day
DDDDD = seconds since midnight

Is using this format alright?

The compiler/IDE should probably be handling this situation more gracefully instead of presenting an unrecoverable assertion. You should file a bug report about this poor user experience.