Slider Valuechanged issue

I have noticed that using a Slider control with minimum set to 0 (like 0 to 100) and setting a value programatically at Window Open event (different from 0) the ValueChanged event won’t fire if you drag the slider to 0 after start.

It fires for any other position and it also fires for 0 if you first set it to another position but not if the first change is to 0.

If the minimum value is not 0, like (10 to 110) it works as expected and ValueChanged fires by dragging to minimum position.

Xojo 2017.3 and Mac OS X 10.13.3, tested with a new project with only a window and one slider.

Confirmed.

But next time please supply a demo project instead of expecting everyone else to create one. It avoids confusion and makes testing quicker. And no, it doesn’t matter how simple it is.

Thanks Markus.

I tried to create a new case in Feedback but this option is greyed out in my Feedback application, kindly let me know how to upload the project.

Do you have a current license? Otherwise you can’t.

Yes, I have a valid license, still not expired. Feedback is 2017r1.2

You need to search for something first aka check if it has already been reported, then the menu becomes active.

Thanks, Marcus.
I already searched first but closed Feedback before trying to create new case. May be a warning to search first after clicking would be easier to understand than greying option.

Case filled:
feedback://showreport?report_id=51760

Please allow me to reopen this thread regarding that Feedback Case #51760 has been closed because “our testing staff has been unable to reproduce the behavior using our latest 2018r1 beta.”

I’m running 2018r1 final and it still presents this bug, as I have no option to reopen the case at Feedback I would appreciate if someone can check this and reopen.

Thanks.

This is no longer true.

I have a valid license.

The only option available at my case is “Make private”.

Use the Add Information icon to comment that it is still broken, it will put the case back into the queue.

Thanks Tim, but I already did some days ago and the case remains closed. May be it will be read by someone and returns to open in short.

Click the pencil icon, and you can add whatever you want.

BTW, I ran your test project in 2018R1 under High Sierra, and it happily beeps…

Except that indeed, the first time around the slider is set to zero, it does not beep.

Then it works fine in any subsequent changes.

I’ve re-verified your case. The problem was that your reproduction instructions were very confusing. When filing a bug report please include the simplest steps without any other extraneous instructions. In this case:

[quote]1. Run Project (notice it beeps because the ValueChanged event fires)
2. Move slider thumb down to the bottom (notice it does NOT beep because ValueChanged didn’t fire)[/quote]