Simple Xojo Youtube tutorial app behaves differently

I am completely new to Xojo (but definitely not to programming!). I figured I would start out slow and follow Paul’s “Creating a Desktop Application With Xojo” tutorial on youtube. (

At 29:02 into the video Paul clicks on the “complete” checkbox for the first row of the ListBox and a red line is drawn through the contents of the second cell in that row. Seems like very intuitive and expected behavior. However, I tried to duplicate the entire application in 2015r1 and when I click on the checkbox I get nothing. But, if I click on the “TASK” header then the row gets the red line. If I unclick the checkbox the red line stays. Click on the “TASK” header again and the red line disappears.

Do I need to do something special to get the ListBox to update?


It seems like some optimizations to ListBox since the first Xojo release might be preventing the refresh from occurring when the checkbox is clicked. You can refresh it yourself by adding a CellAction event handler to the ListBox and putting this code in it:


Paul - tried that, but no joy.

Hmm. Well, here’s a quick example I threw together for you to try:


Paul – I tried your example and it misbehaves in the same fashion. I add an entry and then mark it as complete. It does not get the red line until I click the TASK column header.

Sorry, my quick code works on OS X, but not Windows. This line of code in the CellAction event handler works on both:

Me.InvalidateCell(row, 1)

Paul – that was the ticket! Works like I expect now. Thanks. And thanks for the tutorial too!