Sierra in VM

Did anybody else have issues installing Sierra into VMWare?
It has said “About 7 minutes remaining” since the beginning, and for well over an hour now.

I was able to install it into VMware 8.1 by upgrading a copy of an El Capitan VM. However, it would not shut down properly. I’d always get a “computer has crashed” message when shutting down or restarting (I tried both the Dev Preview and Public Beta). And it was incredibly slow. I ended up tossing it and instead set up Sierra on a separate drive to dual boot.

I am running it on VMware Fusion without having experienced any issues so far.

[quote=279488:@Tim Parnell]Did anybody else have issues installing Sierra into VMWare?
It has said “About 7 minutes remaining” since the beginning, and for well over an hour now.[/quote]
I don’t recall that issue when I installed it. Latest version of VMWare Fusion here, VM saved to internal SSD. Seems fine.

I looked at the installer log and it seems some kind of error was reliably happening.
Not sure what it was, some kind of issue with a plist.

I’m going to attempt the route Paul took.

Amazingly enough, it runs fine in VMWare Fusion 7.1.

But the last beta disabled VMWare tools.

I was considering upgrade, but now I think I’ll wait.

The VMware blog posted some steps last month that I still would like to try:

[quote=279501:@Paul Lefebvre]The VMware blog posted some steps last month that I still would like to try:[/quote]
Ugh sorry Tim, Paul is right, I had to follow the exact steps that VMware posted. And then all was good.

…and if you care, it will also run in Parallels 11 if you install 10.11 first and upgrade. I’ve not had any startup or shutdown problems there.

I did a clean install of Sierra (Dev Preview) using Fusion 8.1 following the steps on the VMware blog and it all worked fie. No more crashing at restart. VMware Tools also seemed to install properly. It also feels a bit snappier™ than before.

As is typically the case, right after posting it was working, things stopped working. Now the dreaded “You restarted your computer because of a problem” message appears again on restart or shutdown. Arg.

Installing El Capitan and updating to Sierra from there seems to have worked.
I have only had the VM on for about 30 seconds though.

I installed Sierra on a clean partition on a 2015 MacBook. Occasionally it reboots by itself, while I’m using it and Safari often forgets what it’s meant to do with links, I click on links and nothing happens. Restarting Safari helps.

It took many installs for me to get Sierra working on its own drive. Of course, I may be pushing my luck with it. I have a 2009 Mac Pro (MacPro4,1) which is technically no longer supported with Sierra (grr), however the firmware has been flashed to MacPro5,1 (the 2010/2012 models). So the Sierra installer works. But I also have an Nvidia GeForce GTX 750 card (I love 4K retina) which is non-standard. So I have to use the Nvidia web drivers, which are only in Beta with Sierra right now.

I first started with the Public Beta, but it had issues: Mail and Messages would crash on launch. Then it would not update to PB 2 (crashing on reboot – all of these issues were probably related to the graphics driver). So I pulled the drive and installed Sierra on yet another drive using the Dev Preview. This worked and it also updated to DP3 without trouble. And Mail and Messages are also working fine.

So fingers crossed for me. I still don’t know what the reboot problem is with the darn VM though. It seems to have started after I resized the VM window to be larger than the 1028x768 default, but going back to that size hasn’t helped.

The crash on reboot problem is caused by the VMware Tools. A thread in the VMware forum indicates this is a known issue when using macOS Sierra as a guest. The workaround is to uninstall VMware Tools and deal with the much slower graphics.

I’m seeing the boot issues with VMWare tools now :confused:

Looks like Parallels is out first with Sierra compatibility (though I’m not sure if it’s host or client or both):

Yes, and when Siera comes out and you upgrade your computers with it, your forced to pay $49,99 per workstation for version 12 of Paralells. I spend quite some money for this tool over the years.

That’s why I switched to VMWare Fusion