Side-by-side configuration error at launch

Using last version of Xojo. I have this error when I try to launch an exe on Windows 10. The app was compiled from macOS.

Was working fine before with previous versions. Any idea why?
all files are included in the folder.

Try building with the “Include Runtime DLL’s” option enabled.
image

tried and same result.

Look at the Event Log after trying to run it (use the Event Viewer). What is the complaint there?

The above error USUALLY is connected to bad/incorrect VC Runtimes installed. Sometimes we need 32 AND 64 versions installed at the same time and one of those is missing causing this error.

You could try this:

Event Log cannot run on my virtual machine (parrallel desktop) for macOS.
Saying I don’t have admin rights.

Your Win 10 ARM platform in a VM may be the problem.

Possible but it was working with older versions of Xojo. Windows is still such a mess, wondering how people can handle it daily :slight_smile: so oudtated. No such pain points on Apple platforms.

A good PC machine, with a good Windows, running a good software has no problems too.

Sometimes the problem is not the OS, but what people do with it.

Do another test. Compile a copy with 2024r1.1. If it does not crash, the problem is Xojo 2024r2 related. If it crashes, the problem is related to your system.