Settings not propagating?

If you design a container control in the editor then put it onto a web page the control appears exactly as you drew it.
however if you go back to the designer and modify the container control, the instances of that container control do not change appearance in the rest of the project at design time and I’m not convinced at they change at run time. It’s like you have to delete the control from your web page and then add the control again such that you get the latest ‘version’ of the control. Same oddities happen if you modify the locks…

Did you quit Xojo before deleting the Control, then run it / load the project ?

Did you try to clear the cache before re-loading the project ?

There are no caches to clear within the IDE.
The changes do propagate to the executable.

I noticed that issue a few versions ago. Since then, I like to instanciate my containers in code using something like

Dim myContainer as New mySourceContainer myContainer.EmbedWithin(pg1, 0, 0, myContainer.Width, myContainer.Height) myContainer.visible = True myContainer.enabled = True

This way, I always use the latest version of the container. I gave an example for a large container that is placed on the top left corner of the page, but you can specify the coordinates as required.

It is quite easy to do and it ensures that you always use the latest container version.

[quote=422020:@Brian O’Brien]If you design a container control in the editor then put it onto a web page the control appears exactly as you drew it.
however if you go back to the designer and modify the container control, the instances of that container control do not change appearance in the rest of the project at design time and I’m not convinced at they change at run time. It’s like you have to delete the control from your web page and then add the control again such that you get the latest ‘version’ of the control. Same oddities happen if you modify the locks…[/quote]

This sounds like: feedback://showreport?report_id=54583

And Norman has already fixed it for the next release!

The Xojo cache folder in the OS folder (somewhere). Check in Xojo 2018r4’s Preferences or do it manually.

Try changing the Super to something else and then back again.