Set an Icon to a custom file

  1. I created a File Type for that Custom File,
  2. I add an icon to it,
  3. In macOS, I set the FileTypes data (read/write),
  4. When I double click on my file (macOS), my application is fired, my file is loaded,
  5. When I drop my custm file above my application Icon, that file is opened (and the application fired if needed),
  6. Right-Click on a custom file --> Opens with… display my application name.

But, I do not have my custom icon on my custom files.

Nota: I set a custom icon for json files and this worked fine… a plist comarison leads to nothing.

What did I forgot ?

PS: that worked fine, long time ago on BOTH macOS and Windows platforms.

PPS: json reading is not yet implemented… in the application (I think I forgot to add it !)

You may want to rebuild the LaunchServices Database. See

Thank you Stephane.

Nota: I have the same problem under Windows…

Now, I will read your linked page.

my hard disk (SSD) write speed increase by 20MBs…

I still do not have the custom icon.

At first run after the Terminal command (Desktop rebuild), I was asked “this is the first time you run application XYZ…”.

I will re-issue the command to rebuild the Launch Services Database (I booted on a High Sierra external HDD).

Then I doubt it’s a problem about rebuilding the Mac desktop database.

It cost nothing to try (yes, I doubt too).

The first (2013 and some following) Xojo versions generate correctly the whole (two differents custom documents icons), them somewhere around Xojo 2015r1 it stopped.

One thing is sure, this looks nicer with the custom icons.

More changes…

Dialogs in GIMP comes into the main screen, no more in the external screen… YEAH !

Maybe El Capitan have troubles… after all.