session.Name - Join is deprecated???

I have a Web1.0 project that I’m writing and it generates this when I do a “Project | Analyze Project”:

[code]Deprecated items that have a replacement

session.Name - Join is deprecated. You should use String.FromArray instead
session[/code]

I’ve addressed all the other items that were flagged but this one is a mystery. I can’t figure out for the life of me what this means in relationship to my session. Has anyone else seen this?

would need to see the line in question in context
sometimes the error is referring to the wrong thing and that is just the point where the compielr gave up trying to make sense of things

That’s just it. There is no line. When I click on the item in the ‘Warnings & Errors’ pane, it highlights the session object in the project explorer on the left side of the screen but that’s it.

Nowhere in my code do I use ‘Join’. So it’s seeing something behind the scenes that Xojo must be doing.

This is what I see:

Certainly would seem to be the case
An error / warning that does what you describe is usually one in code you dont have access to - like in the framework itself

That has to be a Xojo bug. I just tried opening a new Web project, did not add any code or changed except to enable all Analysis Warnings, and did an Analyze. The same error message showed up. Wes, you should file a bug report on it.

Is it still useful to file bug reports on Web1.0 issues when Web2.0 is just around the corner?

Quite probably not
Just dont do a “check project” and that way you only deal with outright errors not warnings like this one

Well, I submitted a bug report anyway. But I suspect it won’t be addressed.

feedback://showreport?report_id=61010

Verified as a bug! Not a critical one but a bug nonetheless.