Saved Xojo Project Won't Compile

I saved a Xojo project to both dropbox and an external hard disk … now I get on another computer, and I can open these projects, but the “run” button is grayed out and it won’t compile or even try to compile. I have tried this on two computers without success.

What about the license ?

No license = No compile.

Also, trying to compile from DropBox is a bad idea.

Run wont work if you are trying to run an iOS project on Windows, or on a machine without XCode
It also wont work while a desktop app is set as ‘64bit’ on versions of Xojo that dont support 64bit debugging.

Compile wont work without a licence key on that machine, and also the iOS/Windows thing

If your original machine was 64bit and you saved the project to run in 64bit and your new machine is 32bit then the run button will be greyed out. You need to go into (left nav) Build Settings>This Computer (or which ever it ticked), then Build (bottom of right nav)>Architecture>x86 32-bit

I solved it. Its an iOS app, and I thought I installed Xcode, but after I re-installed, and restarted Xojo, then it worked fine.

You keep this information / also wrong channel…