Runtime Error - can't find plugin REALSQLDatabase

I have a small application (QueryRunner.exe) that runs queries against a SQLite db. It is in the same directory as a larger application that uses the same database routines. Both were built about 4 years ago and worked fine until recently. Now when I run QueryRunner.exe on a client’s W7/32 machine I get a Runtime Error before the form even loads. The text of the error reads like this:

…/…/…/Common/plugin.cpp: 7534
Failure Condition: pluginEntry Table GetEntry( entrypointName, out)
can’t find plugin method REALSQLDatabase._init

QureyRunner.exe runs fine on all my machines including when on a network drive.

Any ideas?

are you sure the dlls in library folder are still there?

Yes. The other app would not work if it wasn’t.

I have moved known working copies of the app, db and \Libs to both the network drive and local drive of the machine QueryRunner.exe errors on.

well, the error means that Xojo runtime loaded all DLLs in libs folder but did not find the required function.

Could be that some anti virus tool blocked the loading. Or file is missing. Or file is broken.

Thanks Christian!

Rebuilt in 2014r3.1 and works fine. Strange stuff…