Running Windows Xojo on an M2 Air

I installed parallels, and at first launch it asked me if I wanted to download win11, say yes
and voilà… did it.
I did not try Xojo extensively in the VM thought more than launching it…

1 Like

Now why am I not surprised… :slight_smile:

I’m running Windows 11 ARM in Parallels on a 14" M1Max, and all Windows software I’ve tried in it works perfectly well. I can use it as a target system for debugging, installations, and running Xojo built software “in a Windows window” (or fullscreen if I want) without needing to do it on real Windows hardware. (Our Xojo apps are built only as Windows 32-bit and they live happily and speedily in Windows 11 ARM that way).

I’m doing all development with the Xojo Mac IDE, never the Windows IDE. So that’s not an issue.

I do have another question to throw into the discussion.

Has anyone tried installing Visual Studio (the Intel version, not the ARM version) into Windows 11 ARM on Parallels on any of the M1-and-later systems? If so, what was the performance like? I “do” have a Windows laptop that I use to build other Windows components; I’d like to know if it would be worthwhile to try that running under Intel emulation inside of Windows 11 ARM).

It probably has to do with the compiler / linker phases more than the IDE itself. And that may no longer be an issue. Maybe somebody else can confirm or deny it.

Just mentioning it because, if true, and your goal is to run the IDE in the VM then you may want to confirm this first.

Yes, I need to run the Windows Xojo 2015 IDE.
It’s 20/80 whether it feels like running in Crossover (it used to be better… I dont know whats going on there… maybe caches?)

A pro version of 2015 won’t run on current Macs because of OS changes.
My app, compiled for Windows anywhere using any Xojo after 2016, is unusable, so the Windows IDE is essential. I’m desperate not to have to resort to two machines until late beta testing - things were (and still are) better on my 2015MBP

Well well…

I downloaded and installed Parallels 18
It asked me about Windows 11 and installed that in 30 minutes
I copied a Xojo 2015 folder from my Windows machine, and pasted it into the C: drive
Found the EXE, double clicked and it started.
No messages about the chipset… maybe it is only the installer that has an issue?

Update: IDE works fine, compiles fine, performance is fine!

Not sure yet about whether I need to buy a Windows key (probably?)
And I dont need to pay for Parallels for 14 days until after the free trial


Why doesn’t Xojo compile and release the IDE for Windows for ARM?

I thought Xojo was now able to compile for Windows on ARM so what’s holding them back releasing the IDE on it?

That would simplify things as you could just install Windows for ARM on an M1.

My SWAG is the problem is the compiler / linker phases, not the IDE itself (which I understand to be a Xojo project itself, albeit larger and more complex than your typical Xojo project). But just because the IDE can run does not by itself prove that all the tools it uses under the covers are ARM compatible.

1 Like

it is so cheap that you won’t loose that much …

ps: it’s not a pirate copy …

I notice no one is talking about UTM in this thread. Is that not a good option?

Microsoft offers developers special pre-built VM images for testing in Hyper-V, Parallels, VirtualBox, and VMWare (alphabetically).


wtf ??!! windows 11 cost one euro ???!!

To be fair, Windows 11 has a feature like Rosetta so it can run x86 apps on ARM just like macOS can. I believe the first thing Xojo could do is make their installer just run on ARM.


Ive tried this. It demands a EURO address, so I made one up.
Not sure yet if that means post will end up in Dublin! or that they will email to my email address. Worth a try though…

Or even just supply as a zip file… worked for me

Some days ago I went to [VirtualBox] 7.0.2 (, found it is in beta for arm (running on mac), downloaded, and do not installed, yet.

Someone ?

It appears to work…

1 Like

A zip doesn’t get you the file associations, the start menu shortcut, the prerequisite installation, nor the system protections you get for actually installing in the Program Files directories.

1 Like

Have you tried UTM for virtualization instead? One can not only run ARM operating systems, but emulate INTEL. I have Windows XP running on my M1, for instance. UTM works very well for me.


Yes, UTM is for me the best VM available. Highly recommended!

1 Like