Running Desktop app on Raspberry Pi

Hello Everyone.

I’m just starting with Xojo and I’m having real trouble in getting the built applications to run on my PI.

Raspberry Pi is 3b+ with latest Raspbian Stretch

I believe I have configured everything according to the guides (Rasberry Pi Book, Youtube videos and the minimum requirements etc) but the executable still does not want to run from my Pi desktop. I get the option to “Execute” or “Execute in Terminal” but it just drops back to the desktop with no errors to work on.

I can build the app in Xojo fine, I then FTP the executable and libraries folder to my desktop (so not using the run remotely option). Set the file as executable but it still does nothing.

I’ve tried with the example executables (XojoNotes and other examples) so its not the application. I have installed libunwind8 as per the guides.

I’d be most grateful for any guidance as I’m really starting to pull my hair out with this. I realise that there is not much to go on here but hopefully someone on here may have seen this behaviour before.



What is the error?

Try to run your app from Terminal, it should show some error message

Thanks for the quick response Kyryl.

I’m quite new to running apps in a Linux environment so didn’t think of that.

I’ll try it out when I get home tonight and see what I get.

you need to set execute permissions (755) for example

Thanks Derk,

As my initial post states I did set the file as executable. What I did was use the properties/permissions in the GUI and set ‘Execute’ to ‘AnyOne’ rather than any command line. Is that what you are suggesting?

Although I didn’t set the Libraries folder/files to execute, I wonder if that could be it?

Thanks again


You need libunwind8 and also you can do in terminal “ldd /path/to/your/appname”
To see if you have all libraries installed

In terminal:
“sudo apt install libunwind8” or remove the 8 not sure

Hi Derk, Kyryl,

Got back home and have a little more information:

  1. I have libunwind8 installed (as per the Xojo guide)
  2. Execute is enabled on all files and the Libraries Folder
  3. Ran the Executable from a console window (launched from the desktop) and I get “Segmentation fault”
  4. Ran “ldd /home/pi/Desktop/XojoNotes/XojoNotes” , as you suggested Derk, and I get “not a dynamic executable”

The “not a dynamic executable” is tarting to make me think there is something wrong with the compile but I can confirm that the Build Settings within Xojo is set to Linux and ARM 32-bit.

I really I hope I’m not doing something really dumb here.

Thanks for all your advice so far guys.


did you transfer in ASCII or Binary mode?

You will want to transfer in Binary

or try to ZIP and unzip on RPI. Broken binary is good idea


Many, Many thanks. Zipping up the executable, FTPing it over and then unzipping it worked!!

I don’t think I’d ever have figured that out by myself.

So glad I’m part of a community that is so helpful and giving.



And just for completeness, I just checked, setting the transfer mode to “Binary” in my FTP client (I use Filezilla) also works. I don’t need to zip up the file if I use Binary mode, it just works.

obviously ASCII mode does something to the file that renders it useless

probably translates line endings which would be VERY significant for an executable as that could be part of an instruction that got whacked and that would ruin the executable (ie. if you’re on Windows and line endings could get translated to Unix)

binary just sends those exact bytes without trying to do any translation