Run, Build (acting strange....)

So I’ve noticed occasionally throughout my use of XOJO and back to Real Basic even that sometimes… both running and building an app will appear ‘suddenly’ not to work. Run will appear to compile step 1 or 2 of 3 and then the green arrow switches to resume and than run again like nothing happened…

I can see the debug folder get created and disappear …

Build will appear to work and then open the folder of the exe location and then… the exe will not run. There are no errors when double clicking it… it simply does nothing when double clicked…

I tried removing the xojo folder from %appdata% and I tried closing and reopening… I even changed the physical location of my project file … Up until now… doing various things like this have done the trick… but this time… its still doing the same thing no matter what I attempt to do.

Has anyone had this issue?

symptoms:

  1. play does not play
  2. there are no syntax errors
  3. build will build an exe, however that exe will not open (no errors)

other info:

  1. there are no relevant processes running
  2. have tried removing xojo appData as well as moving project files to new locations
  3. have tried closing and reopening xojo

Can’t say I’ve had the “Build” problems you’ve noted, but I certainly have had the strange “Run” happenings … Asked the same question on the forum here some months back and no one responded (making me think it must not be a very widespread issue). I can hit Run, looks like something’s happening … lights are flashing, gates are down … and train never comes (Run button returns to its “green” idle appearance). Hit Run again (and sometimes again and again) before it actually compiles anything and really runs it. There’s no rhyme or reason to it as far as I can tell … happens on real small apps or real big ones. Can go a week or more without it happening, and then it seems to pop up out of nowhere for a few Run attempts … and then go away again for another week or more. One of those things I’ve just learned to live with, I guess.

Check virus and firewall & security settings
They seem to randomly block the app being debugged from being started

I’ve seen this answer in spots before, Norm but never really asked … other than checking to make sure that Xojo is an “allowed” program with my Trend Micro (which it has been since Day 1), what all else should I be checking? Specifically, what would I expect to find that would be causing the “blockage” with a Debug attempt?

Its the app being debugged thats being blocked as it tries to connect back to the IDE (not the IDE trying to connect to the app being debugged)
You’d need to somehow allow those (which of course vary in name from one app you’re making to another)
And some antivirus block those as well

I dont run Windows as my primary OS so I’m of limited help in this regard.
I run it in a VM, unconnected to the internet, so I can turn all the firewall & AV settings completely off and don’t experience these issues.
But those are things I’ve seen others report as issues that cause this kind of behaviour.

the smart ass answer here is

How to fix this ?
Get a Mac.
Run OS X.
Stick Windows in a VM (where it belongs)
Skip all the silly AV and firewall issues Windows thrusts upon you
Life sucks less :stuck_out_tongue:

[quote=125684:@Norman Palardy]the smart !@#$% answer here is
<start smart !@#$% mode>
How to fix this ?
Get a Mac.
Run OS X.
Stick Windows in a VM (where it belongs)
Skip all the silly AV and firewall issues Windows thrusts upon you
Life sucks less :stuck_out_tongue:
<end smart !@#$% mode>[/quote]

I think we need to get you down to that tropical paradise in Costa Rica you’ve intimated in the past so you can chill out and become a “kinder, gentler, Windows” man, Norman … besides, Winter is only a week or two away from you up there now, isn’t it? ^^

Costa Rica aint going to make Windows any more palatable :stuck_out_tongue:
Today it feels like winter has already started :frowning:

I love windows. But I like mac too.

Dang so no amswer. Surprising.

In my particular case, this would not go away, no matter what I did for one specific project file, while others worked fine. It turned out that APP class did not have a default window set. After i switched the default window to mainWindow, no more problems.

Love Mac. Use Windows (no love relationship) :wink: