RPi not Launching after receiving file

Hello, XOJO community,

I’ve upgraded my Raspberry pi 4 to Bullseye, and when I remote debug the application is saved as a .tar.gz file and does not launch after receiving it. When I try to extract I get Can’t open the archive popup. Please advise.

  Operating System: Raspbian GNU/Linux 11 (bullseye)
  Kernel: Linux 6.1.21-v8+
  Architecture: arm64

Offhand, I would suggest making sure that 64-bit ARM is your Linux build setting in the IDE. I’ve had occasional remote-debug issues over stuff like this.

That’s what I thought, and when I switched from 32 to 64 I still get the same error.

And you’re building for ARM and not Intel, I hope.

I’m not near my computer so I can’t check this but…

Is there a 32 & 64 bit Linux ARM debugger stub?

Yes, both exist now.

Yep the build setting is for Arm 64

The debug application is being transmitted. I’ve also noted that I get this message in the Editor debug window.
The remote debugger stub could not be reached on the target computer. Incon its cut off and it only lasts a brief pause.

That may point to a firewall problem. The stub needs some ports open, one for file transmission and one for communication. Sounds like the latter is closed or maybe already in use?

If you are using a firewall on your development machine, you need to make sure that port 44553 is open for UDP and TCP connections and port 13897 is open for TCP connections.

Decided to re-install everything, and it works! :grinning: Thank you for all of your assistance.

1 Like

What did you reinstall? The operating system or you Xojo program?
I have a program that works on Buster, but won’t launch on Bullseye.


Operating System