RPi Excitement

Excited that RPi is finally publicly available! Thanks Xojo for all your hard work!

Yes, I too am excited was wondering if I Can directly access the RPi Serial port, ethernet ports using sockets, have disabled it from the console at start up. I understand that for GPIO need to use the GPIO module, don’t find the serial port there hence the question

Have you tried something like this?


ethernet ports should be no problem, and as far as I can see the serial ports are supported too. Not via a socket, but via the regular serial control in Xojo. I THINK, but I’m not sure if it’s still that way, that by default the serial port on the Pi is setup as a terminal so you need to disable that if it’s still setup that way. Mine just got connected to it’s screen and I’m making an image for it to boot from now so I can’t test yet. You may also need to get a serial port level shifter if you want to connect to an RS232 device. The ports on the Pi are TTL level, so 0-5v which is not compatible with RS232 levels directly. You should not need to link in any GPIO library stuff to use the serial port.

Don’t forget that there is a RPi Webinar in 10 minutes.

https://www.xojo.com/support/webinar.php :slight_smile:

And not only Console Apps I expected, but the whole GUI framework ported to the Pi. What a fantastic release!
IMO, LLVM is the best of this release. Now Xojo is much much faster in every platform! Really much faster!

Thanks to all Xojo staff, impressive work you’ve done!

Heres a bunch of ‘everything you ever wanted to know about pi’ articles. Now that Xojo is supported, there will be less python articles :slight_smile:


Yesterday late afternoon ( for us in Italy ) we have seen the webinar,
today we have received our Raspberry,
and in less than an hour the system was installed, the little baby configurated, and running a test Xojo app…

that’s fantastic, me and my associate friend are here like two 50 years old babies playing with a wonderful toy :slight_smile:

I tried to use a serial port on rpi2 circuit board. When checking the names of port program detects the port with name : /dev/ttyAMA0 , but it is not possible to connect to this port. I used TTL converter (Max232).
I tried the USB-RS232 adapter ( /dev/ttyUSB0). By using the adapter application works perfectly.

After reading this :


Serial port on RPI 2 works normally.

@Boštjan Škafar, you think that might work with the Adafruit GPS Breakout?
Online I have seen a tutorial that covers a nice example of this being used with Python. But Xojo is not Python. In Python a serial class had to be imported in order to deal with it.
Do you think the serial class in Xojo can deal with this?

You can use NEMA serial commands from gps and extract the values. Most gps use NEMA serial streams.

I knew about the NMEA sentences. But thanks for the input :slight_smile:

I saw a nice tutorial about a GPS shield on youtube. It is for Arduino. But this Paul guy explains clearly how the NMEA data can be interpreted.
It is fun to see what kind of projects he has. He actually has Raspberry Pi tutorials also. Though they are for Python (not Xojo), they are fun to watch. Python is not that hard to learn.

Paul McWhorter does a very good job as a teacher.

I had to wait forever. But I finally got my piece of Pi this week. It is a plug-and-play kit with a 7" touchscreen. It was more like Plug-and-pray for me though. The screen didn’t seem to work at first. But jiggling the ribbon cables attached to the screen did the job.

Next I am going to do is experiment with the Blinking Led examples by @Paul Lefebvre and play with a GPS receiver.
The GPS bit will be kinda tricky because I will have to activate a secondary serial port on the Pi. And that secondary port actually does exists.

I do have a 32GB micro SD with it. Enough space to play, right? An additional 128GB will serve as GPS storage. The 128GB micro SD is plugged in a tiny USB reader, which I have installed in one of the 4 USB connectors. It actually does work. I had to format it to FAT32 though. Although online I have seen people to get it to work with ExFAT.