Remote Debugging

Still working on solving my issue. So I thought I would try remote debugging.

Develop machine is Mac
Webserver is Linux

Got it all configured and the remoteDebugging Then went to Xojo IDE and launched it, the console shows:
PM: Response accepted
04:06:57 PM: Decompressing DebugCEUCertificateMailer.tar.gz
04:06:59 PM: Untarring DebugCEUCertificateMailer.tar
04:06:59 PM: /home/aspe/public_html/xo/CEUCertificateMailer/DebugCEUCertificateMailer.tar.gz was unpacked
04:06:59 PM: Stub->IDE FILEUNPACKED, File ID: 0

The IDE says waiting for application to launch. I then realized the the debug app is in it’s own directly and named DebugCEUCertificateMailer.
This app requires a long parameters.

So how do I launch it there is no cgi?

This will be cool if it works.

You can set those parameters in the event.

But I also suspect that you’ll need to launch the app from the terminal yourself.

OK, I’ll give it a shot.

@Greg O’Lone

OK I tried running it from the terminal:
Failed to load plugin cannot open shared object file: No such file or directory

The is in the DebugCEUCertificateMailer/DebugCEUCertificateMailerLib forlder

Any ideas??

That’s Valentina. Is it in the plugin folder?

Yes it is.

Perhaps this will help…

Actually I should have spotted that. Anyway now I’m getting the error:

V4RB: PluginEntry()
V4RB: DisableRBDB file IS NOT found. Enabling RBDB.
Could not locate the target IDE for debugging.Since we could not locate the target IDE to start a debug session, this application will now exit.aspe@aspe-web-cp

Thanks for helping!

This is typically caused by a firewall blocking the return communications. Once the app launches, it tries to create a direct connection back to the IDE and if it can’t do that, you get this error.

that would be 44553 correct?

I’m trying to find telnet on the linux web server to test but it doesn’t seem to be there.

It’s not installed by default any more because it’s not secure.

I guess I have to wait till Monday when the people that administer out server are in.

If you are using a firewall on the remote machine, you need to make sure that port 44553 is open for UDP and TCP connections and port 13897 is open for TCP connections.

@Greg O’Lone

OK Got the ports open, launched it from ssh terminal. It now says:

Application is ready

Now how do I get to the running app. I tried entering a url to the DebugApplication and got a 404.

Should be http://IPOfDebugServer:port

Thank you!!1

General Remote Debugging docs are here: