Remote Debugging on Linux

So, I followed the directions here: (great write-up, btw)

Copied the Debug Stub onto my Debian Linux system, under a directory /root/debug/ and then ran the ‘./RemoteDebuggerConsole’ and went through the setup step process. Got it all finished. Configured my Windows IDE properly, and go to remote debug an app… then I get the following on the Linux system:

ServerSocket1 is Listening on
01:14:58 PM: Stub->IDE OLLEH, 1.9.0fc43, 6, Remote Address:
01:15:04 PM: Decompressing Debugmyapp.tar.gx
Launching /root/debug/Debugmyapp/Debugmyapp
bash: linux: command not found

Anybody with experience with remote debugging on Linux has any ideas what is going on? When I exit the remote debugger, it successfully created the ‘Debugmyapp’ with the appropriate files and Libs directory inside it. Is it a permissions issue (chmod) or something else?

Another find… after exiting the remote debugger, when I run ‘/root/debug/Debugmyapp/Debugmyapp’ from the command line manually, it appears to load fine (except for the closing because the debugger wasn’t found message).

Sounds like a path issue. Did you try launching the debugger by double clicking? It sounds like you’re running it from the command line…?

It’s run from the command line. My Debian install has no GUI, only uses the bash command-line interface.

Now that you have the config file, launch the debugger in the background with &. When it says that your app has been received, launch your app manually.

I can’t offer much help beyond what Greg said, but the error you’re seeing means that the bash shell can’t find the command “linux”. I have no idea where that would be coming from. Maybe an unescaped path called by the stub? What version of Xojo are you using? Maybe try a different version. 2013r3.3 works fine for me, while 2014r1 can’t even launch (Could not resolve function ‘__error_location’ in -I see that’s fixed for a future release though.

Greg, still doesn’t work that way. The app won’t launch because it believes the debugger isn’t running.

Quick question, is the debugger stub looking for a path with ‘linux’ in it by chance? I tried putting the parent path as ‘/linux/’ and the stub just seemed to have froze after the ‘Launching /linux/Debugmyapp/Debugmyapp’ part (no error returned, but then again… nothing returned and the ‘Debugmyapp’ didn’t execute).

Just out of curiosity… if you build the app and copy it to the server, does it run? This is really starting to sound like there’s a missing dependency.

Yeah, that’s what I’ve been doing since the debugger doesn’t work.

Helo Eric, Have you solved your problem? I have the same problem. Can anybody help me ?

root@databaseserver:/home/xxx/Remote Debugger Console# Machine Name: servidor
Download Directory: ./
IP Address: X
Port: 44553
Max Connections: 5
Launch After Unpack: true
Public Stub: true
ServerSocket1 is Listening on
06:53:53 PM: Stub->IDE OLLEH, 1.9.0fc44, 6, Remote Address:
06:56:43 PM: Decompressing DebugSocketServerTrackingCT.tar.gz
Launching /home/supercarlos69/Remote\ Debugger\ Console/DebugSocketServerTrackingCT/DebugSocketServerTrackingCT
bash: xterm: command not found

My application runs ok without debug, but I need to debug this.

Thank you.

Here is a workaround tested and working on Debian & Redhat Linux for me. :slight_smile: