Quitting within Linux

Hello,

I have some troubles while Quitting with the actual IDE. After opening some windows and closing of them, the quit method doesn’t work any more. The close event of the event is not reached. It makes no matter if I use a CancelClose event or not.

I tested a little bit with different windows. It seems that it may come from a Container. But in another app I have the same effect - but no container.

Does some else has such effects. I use the actual IDE 2018r3

This older thread might help discussing open or circular references holding up the Quit: https://forum.xojo.com/16578-app-quit-not-working/0

Hello,

this was not the solution. The problem occurs only with Linux. With macOS and Windows it works. Also with the former IDE it worked. I investigate a little bit more in the controls in this dialog.

I didn’t found a reason, but it seems that it depends on the controls on the window. I created a new window and copied all controls to this windows. For one application this worked. But with the next it didn’t worked when I copied the about tenth control. But it was not this one. With the next try it was the control before or after this.

Today I try to create all controls new…

Today I created the window with the controls new. But after adding a number of controls the effect is there, again. the good thing is, that I was able to create a test project. So, I wrote a feedback ticket against Xojo. I hope they will fix the problem.

This is the issue… but…
in this case, it’s a Framework issue.

Stripped down to this layout: Windows -> Page/Tab-Panel -> Groupbox (on Panel 1) -> a Control in Groupbox

Show this Modal Dialog. Close.
And guess what - GroupBox and it’s Child Control is still in memory. And back to @Eric Wilson 's answer: therefore preventing the Quit.

So to me it seems that @Manfred Richter has found a reproducible way in feedback://showreport?report_id=55120 for the Framework to create some “memory leak” causing Controls to stay alive, and as a side-effect prevent the app to quit.

I hoe this will be fixed in the next version of Xojo. And thanks Jürg for the investigation in the problem.