Publish a XOJO application on the app store

I want to publish an application (made with xojo) to the app store.

I already have an apple dev ID and added an app into itunes connect.

Now, my problem is when I’m trying to load my app through the application loader, I always have these error lines :

The archive is invalid. Unexpected productutil output: the product-metadata must be present. Product archive "/XXXX/XXXX/My App.pkg" is a directory

I followed the instructions of the old post : but it won’t work…

I edited the info.plist of my app, signed the .pkg, I think I’ve done everything right but still doesn’t work.

I saw number of posts in many forums, but I find nothing to fix this and I really want to publish my app ASAP on the app store.

Is there a procedure or any solution?

I would strongly suggest using Ohanaware’s App Wrapper to prepare your app. I have 2 apps in the MAS and am preparing my third. I use App Wrapper for preparation and have had no problems with acceptance. It basically takes care of all of the prep for you and warns you if it finds things in your app which might trigger a rejection.

I tried to use App Wrapper but there is an issue warning when I start it :

[code] There are some files missing which will prevent “App Wrapper Mini” from being able to Code sign applications or build installers
“codesign_allocate” is not installed, this is required for code signing applications.

Please download the “Command line tools” from the Apple Developer section on the Apple Web Site. [/code]

But i already have installed the command line tools with XCode and don’t understand why codesign_allocate is not recognized…

So many troubles for publishing an app…

I can’t answer your App Wrapper question, but contact Sam Rowlands. He has been very good at responding to my requests for help.

Thanks for your answers

I check and the app codesign_allocate is on /Applications/

Do you know it I have to copy it somewhere else?

I sent a message to Ohanaware with my question about this issue… Wait for an answer!

Have you downloaded and installed the latest Xcode from the App Store? This caught me a couple of times.

Ok so, I downloaded and installed the last version of the Command Line Tools and App Wrapper seems to be working…

I’m gonna check if it really works fine for me, to deliver my App on iTunes Connect.

Now it is ok, after many tries, it works!!! Thanks everybody!