Promo Codes

I have given out promo codes before without issue but last night I issued one and the user couldn’t use it. The error said This requires IOS 14.2 but it was a MacOS App
Is it something I am doing wrong?

1 Like

If anyone has time to check
App - Crossword Wizard




Most likely this is a problem at Apple’s end.

Is your app available on your own site? If so, I’d recommend using that instead as it has a higher chance of working.

Yes I have it on my site so will direct the user to download from that location.

1 Like

Pay attention to the marked yellow message:


Maybe you are using some deprecated IAP protocol / SDK ?

Currently using MBS Store

Maybe you could send some sample to @Christian_Schmitz to investigate.

What version of MacOS is this?

Maybe your macOS is too old?

Ventura 13.2.1

I started this thread in the general target area by mistake

I have an App with 2 IAPs.
When I look to generate the Promo codes I see there is a promo code for

  • The App even though it is free
  • Promo code for IAP1
  • Promo code for IAP2

When I tested I enter the App promo code and it said it was downloading the App but I can’t find it.
When I tried to enter the codes for the 2 IAPs it gives this error about the IOS version but it is a MacOS App?

I just tried downloading it again and it downloads the App then deletes it from the App folder??


Ok App Store is a bit cleverer than I thought, it realise that my latest version exists in the App Wrapper folder so it downloaded to that location instead of Applications folder.

It uses apples package manager, which is pretty cleaver at finding copies of your application in which ever place you find them. I tried the installation package generated by AppWrapper locally and it reported that it had found my app in three different locations and offered to replace each of them. That surprised me.

1 Like