Project won't run

Compiled my on lifetime project today few hours ago - all was well. Now wanted to add two lines of code and caboom! Not runs anymore! Says nothing - just when I click to run lightly says “Done assembling code” and nothing happens. Even if I make new empty project - same behaviour. I have Windows 7Pro 64bit and Xojo 2015r3.2.
Looked with Trace Spy:

[quote]Command “NewProject” handled by App
pre build
Skipping property Backdrop of type Picture with value 0
Command “Kill” handled by Window “xxx”
Command “RunApp” handled by Window “xxx”
What happened? :frowning: Please help! What means that “Command ‘Kill’”?

Virus checker installed?

No - but just in case switched it (Avast Pro) off. No good - all the same. Even earlier Xojo’s don’t let code run. RealStudio works. :frowning:

Clear your Xojo caches?

Little advise? Searched there, but…

What platform? On windows, nuke the contents of \Users\\AppData\Roaming\Xojo\<version #>\projects

Hmm - found C:\Users\llar\AppData\Roaming\Xojo\2014.032.00.fc.28562\Projects, There are plenty of them, but they are empty instead of one and that one works - empty ones did not…

And no good - emptied it - made new project with name xxx - folder appears after clicking to run , but it is empty

Since you compiled it as 64bit, you can’t run it in the debugger… so why not compile it as 32bit and see what the debugger says… or perhaps it will work in 32bit, and that would indicate either an issue with XOJO 64bit implementation, or your interpetation of said.

No, no - sorry - my bad mistake - I have Xojo 2014r3.2, not 2015, so I can’t do that. But - as I tryed now - very odd is, that it builds and makes exe that works well, but clicking to Run says only that “Done assembling code” and nothing more happens.

I’ve had this happen before when I was debugging both a web app and a desktop app. The web app will block the desktop app from running in debug mode. I needed to start the desktop app first. Could this be the case here?

Nope - It’s only desktop app. Both of folders (debug and build) Xojo must make to project folder as it made earlier. Building is well - works, but debug folder did not appear. Even if I make empty project Xojo builds it and result works, but Run button don’t writes any folders or files…
What means that Command “Kill” handled by Window …
And I had some projects where cache folder was not empty - they worked, but now - after deleting the cache - they wont run anymore, but builds well. Folders in cache appears, but they are empty. Very strange…

Delete the Precompiled Plugins as well.

Okay - seems to be problem solved. I made chkdisk for system disk - and now run functions. So Wayne - your notion was nearest - probably there were some broken file allocations or rights. Many thanks to everyone for kind help.
When it happened, the first fright was very big, as project I’m working is already long-lasting and will go on. But now - my night is saved. :smiley:

make sure you have backups
lots of them

Thanks - this advice is everlasting - I have lots of them. :slight_smile: